WiGig always attaches to PhysX GPU

TruWrecks
Settler

WiGig always attaches to PhysX GPU

I have tried putting the Wigig card in all 3 available slots in my system. I have 2 GPUs.

 

Build:

Threadripper 2950x on a Gigabyte X399 Gaming 7 TR4 Motherboard BIOS v F11e

64 GB DDR4 Corsair 3000 MHz

PCIE Slot 0 - RTX 2080 Ti - Bus 43, Device 0

PCIE Slot 1 -Samsung 960 Pro NVME 512 GB - Bus 38, Device 0

PCIE Slot 2 - Wigig Intel Wireless VR - Bus 14, Device 0

PCIE Slot 3 - Empty

PCIE Slot 4 - GTX 1080 Ti (PhysX) - Bus 8, Device 0 - (GPU is for testing only and has no display attached.)

PCIE Slot 5 - Samsung 950 EVO NMVE 512 GB - Bus 6, Device 0

PCIE Slot 6 - Empty

 

Windows 10 Pro Build 1806

 

 

Of the 3 slots I can use, it doesn't make ANY difference because the Wigig card ALWAYS attaches to the card on the lower Bus (Bus 8) and SteamVR find the HDM on the 1080 TI but everything else is on the 2080 Ti.

 

I have disabled all Cuda Cores on the 1080 Ti Globally in the Nvidia Control Panel. I have setup profiles for SteamVR, Intel Wireless, Vive Wireless utilities and openvr.

 

I cannot swap the card positions. The 1080 Ti is phisically too large to fit into the slot that the 2080 Ti currently is mounted into so that is not an option.

 

I have tried defining Registry entries and manually changing the SteamVR defaulvrsettings files to try to override the GPU it is using to no avail. I have also tried adding Graphic Options to Windows Programs in Settings to override the GPU that is being used. Windows only offers the 2080 Ti.

 

The only wave I can get Wireless VR to function on my system is to either remove the 1080 Ti every time I want to use VR or disable it in the Device Manger. The first option is not happening. This is a development system. I make game worlds for Unreal Engine games and I need the GPU performance that the second card gives me in the UE editor and compiler.

 

I need a better sollution to lock SteamVR, Vive Wireless or the Intel Wigig card to the 2080 Ti at the software level, since changing hardware around did nothing to help.

 

I have been fighting with this for several months. I opened a ticket with Intel (since they made the Wigig card) and they said it was an HTC issue. Hopefully someone here can help or has an idea I have not tried.

 

Any suggestions would be much appreciated.

Drathian
Contributor

Re: WiGig always attaches to PhysX GPU

I've run into a similar problem for some other issue unrelated.  I have an nvidia optiumus GPU with an attached EGPU, the only way i could get this to work right for certian games to use the proper GPU is in hardware device manager (devmgmt.msc)  select the gpu you don't want to be using and then go to the menu and select view > devices by connection and disable the pci-e port that it is attached to.  This shouldn't require a reboot and to re-enable the the card, click on the disabled port in device manager and > enable.  Dunno if that was helpful.  Good luck.

Vive Staff

Re: WiGig always attaches to PhysX GPU

@Drathian @TruWrecks,


I've confirmed as of last week that enhanced multi-GPU topics are currently being explored by the hardware team that supports the wireless adapter and its companion app. They're currently exploring ways to increase the level of support for customers who have multi-GPU setups such as the one you described. There isn't any firm word to share on any potential updates they're considering building out - I just wanted to let you know that we're taking a much closer look at this, in part, because of this thread. 

To reach Viveport's customer service team, email customerservice@viveport.com

To connect with a live support agent for hardware support, go to www.vive.com/support, click on "contact us" in the top righthand corner, and then opt to speak with a Live Chat agent

David R

Technical Specialist - San Francisco, CA; Monday-Friday

Click here to send me a PM

TruWrecks
Settler

Re: WiGig always attaches to PhysX GPU

Thank you for sending this to the tech teams! It is not a deal breaker but will make this much more system friendly with thousands of computers if there was a software switch to select which GPU to bind the WiGig card to before we start SteamVR.

 

For now I will have to keep the PhysX card disabled when using VR.

Vive Staff

Re: WiGig always attaches to PhysX GPU

@TruWrecks ,

This affects developers and enterprise users so it's certainly a situation that's now on our radar and we're evaluating a response. It's a complex product and so the current use-case for the product is primarily geared towards a standard consumer use-case. 

To reach Viveport's customer service team, email customerservice@viveport.com

To connect with a live support agent for hardware support, go to www.vive.com/support, click on "contact us" in the top righthand corner, and then opt to speak with a Live Chat agent

David R

Technical Specialist - San Francisco, CA; Monday-Friday

Click here to send me a PM