Vive Pro audio quality

Highlighted
Angelus
Pioneer

Re: Vive Pro audio quality


@PanFX wrote:

@AngelusDepends on what you refer to. Technically, audio is working very well so far. If not, something is wrong on your end.


you're not telling the true story...

 

first things i tested is pushed the headphone against my ears ,still no bass...

 

also many ppl on reddit said they dont have bass tone even 100% fit their ear size...

 

right now all we can do is  turn on the bass enhancer for better audio quality....

 

btw I A/B tested Vive Pro and DAS many many times , 100% sure the Bass tone on Pro have serious problem ...

 

 

PanFX
Pioneer

Re: Vive Pro audio quality

Well, i don't recall that a technical support forum is used to tell stories. We are here trying to help each other by sharing advice and experiences. On my end the speakers are working very well within their technical specifications, considering their form factor and the supra aural design. This means they deliver as much bass as they technically/physically can. It's not the super subwoofed boom, but pretty okay for their size. Like i already stated "If not, something is wrong on your end." Change your USB ports to a free USB controller with high bandwidth, try changing the audio source (HDMI <-> Vive Pro multimedia) back and forth again. Try switching the camera on and off, that settles the issues for most people.

Mura
Visitor

Re: Vive Pro audio quality

Hi Everyone, 

 

Apologies if this has already been said, but have you tried:

  • Go into "Playback Devices" in windows audio settings
  • Select the Vive's audio device (usually there are two - the HDMI device and the USB device - this works for either)
  • Go into the device's properties, then navigate to the "Advanced" tab
  • Change the sample rate from 48000 to 44100 and hit "Apply"
  • Click the test button and it should sound normal
Aloter
Visitor

Re: Vive Pro audio quality

Try adapter with DAC inside... Like HTC sell for pixel 2...https://www.amazon.co.uk/gp/product/B078GLX8ZG/ref=oh_aui_detailpage_o02_s00?ie=UTF8&psc=1
MartinMarty
Architect

Re: Vive Pro audio quality


@Mura wrote:

Hi Everyone, 

 

Apologies if this has already been said, but have you tried:

  • Go into "Playback Devices" in windows audio settings
  • Select the Vive's audio device (usually there are two - the HDMI device and the USB device - this works for either)
  • Go into the device's properties, then navigate to the "Advanced" tab
  • Change the sample rate from 48000 to 44100 and hit "Apply"
  • Click the test button and it should sound normal

Thanks for the suggestion. I tried it this morning and for me it did not improve anything beyond what all the other fixes/tricks have done.

 

I have also been playing with a couple of Windows EQ programs, such a FXSound Enhancer 

http://www.fxsound.com/webapps/index

 

Another one is open source Equalizer APO 

https://sourceforge.net/projects/equalizerapo/

 

There might be some hope there but it gets really confusing between all the various games we're playing and I'm about running out of ambition to work on this problem. If anyone else feels like playing around with those I would love to hear feedback. Having done some testing already, in retrospect I should have undone all fixes and then installed one and only one ehancer program at a time. That way there aren't so many variables to juggle.

AGR-13
Explorer

Re: Vive Pro audio quality

Hello HTC

 

I still have the same problem of poor audio quality - still having the workaround active using +12db bass on 80Hz in Windows audio devices. 

 

Could you please provide some news on this issue and the progress of solving it?

 

Thanks for a swift answer

andino
Explorer

Re: Vive Pro audio quality

Ok.

 

So now everything sounds distorted and there is still very little bass. 

 

I'm getting tinny crackling on every game.

 

 

andino
Explorer

Re: Vive Pro audio quality

I uninstalled SteamVR. Reinstalled it. Still get distorted audio. I don't have audio mirroring on either. I moved my USB around to another port and still audio distortion.

 

 

This is getting really really old...... 

Lestaticon
Pioneer

Re: Vive Pro audio quality

I was away a couple weeks and, upon my return, found a firmware update notification for the HMD in SteamVR. (An actual firmware update, updated the firmware present on the HMD).

 

It appears to have updated a couple firmwares, specificaly the Watchman. The audio firmware appears to be the same, but I'm no expert. Does anyone know what this firmware changed?

 

I also has crackling audio after this firmware update. I powercycled the HMD (removed power from the linkbox, and disconnected the HMD cord from the linkbox, letting it sit like that several minutes before plugging it all back in and turning it on). I also changed BACK the audio sample rate from 16 bit 44100 hz TO 16 bit 48000 hz. I believe I also rebooted after that. Eventually, one of these steps resulting in the audio clearing up again.

 

edit: and here is my current firmware information from the SteamVR System Report

Device 1 - Headset VIVE_Pro MV HTC LHR-977A625F
Firmware:	1526689969 watchman@runner-watchman 2018-05-18 FPGA 531(2.19/7/2) BL 1513896911
Hardware Revision:	product 133 rev 2.0.6 lot 2000/0/0 0
Hardware Id:	0x85020006
Watchman Firmware:	1526689969 / 1526689969 (2018-05-18) 
Watchman FPGA:	531 / 531 (2.19) 
Dongle Version:	E1818A69FE Version: 1461100729 / 1461100729 (2016-04-19) 
Dongle Version:	51C8F36B0E Version: 1461100729 / 1461100729 (2016-04-19) 
Camera Firmware:	12884967859 / 12884967859 (Version: 03.01.1B3 Date: 2018.Jan.11) 
Display Firmware:	2105635 / 2105635 
Display FPGA:	6 / 6 
Display Bootloader:	1056771 "0x0000000000102003"
Display HW Revision:	2 "0x2"
Audio Firmware:	6 / 6 
Audio Bridge Firmware:	288 / 288 
Image Bridge Firmware:	9 / 9 
VSync to Photons:	0.0004
Display Frequency:	90
User IPD (m):	0.0636
Current Universe ID:	1472096683
Previous Universe ID:	0
MartinMarty
Architect

Re: Vive Pro audio quality

Thanks, @Lestaticon. That gives you a newer version of watchman than I have. Steam does not want to update my headset, so it must not be important. I tried update Steam Client also, but nothing.

 

 

Lestaticon
Pioneer

Re: Vive Pro audio quality

However, when I updated Windows 10 to 1803, I get the distorted audio issue. (crackling) I noticed that switching the audio device to the Vive Nvidia audio device, it clears up. However, as soon as I switch back to the Vive Pro audio (the usb one), audio crackles and SteamVR may lose the status of the HMD and base stations. (tracking lost and base stations show as off even though they are on). I had to revert Windows back to 1709 to correct that issue. https://pureinfotech.com/uninstall-windows-10-1803-april-2018-update/

However, as part of the troubleshooting process, I uninstalled all Vive drivers and software. There is a new Vive Pro software installer on the website and durring part of the process you must "sign in" to your HTC account. Pressing sign-in does nothing so I cannot continue the install process. This leaves me with a broken install and software entries in add/remove programs I cannot remove. I've read posts here from others with similar issues with the "sign in" button (but using different installers or the regular Vive instead of pro) and have tried switching my default browser from Firefox to Chrome and even IE to see if that made a difference. It has not.

 

EDIT:

I realized that the bigger Windows 10 updates tend to mess with drivers often, especially third party ones like, I assume, the Vive's, Nvidia's, and Createive (my external usb DAC). I cleanly installed my DAC and GPU drivers. I also removed any other instances of them from device manager (show hidden devices). After cleaning all of those and removing the Viveport service which was still there even though the exe was not, I redownloaded the HMD install exe from https://www.vive.com/us/setup/vive-pro-hmd/ 

Once it downloaded, I right clicked it, opened properties, and checked off the "unblock" box at the bottom, just to make sure there were no issues there. Previously, I had also made sure my default browser was chrome. As an additional step, I also went to "set defaults by app", selected chrome, and made sure all the set protocols there were also chrome and not firefox. Of course, there were numerous reboots throughout this process and I am still on windows 1709 and not 1803, which was even more problematic. 

Now the "sign in" step worked. I plan to continue the installation later when I'm home and retest the audio again. 

 

EDIT2 5/31:

After all the effort above, I managed to get the vive software installed.

I received an error that viveport could not be installed during the process. I had to run the viveport installer exe manually from program files and choose "repair" to get it working. Audio is no longer distorted. All other issues with audio aside, and with the new silence from HTC about it, we are perhaps on our own at this point. @PanFX 's awesome 3d printable springs for the headphones has helped a lot too and gives more ways to improve the experience.

If I am courageous enough, I may try updating to windows 10 1803 again. However, before doing so, I plan to uninstall all the vive software and drivers again, cleanly, uninstall my creative external usb DAC, and then do the update. After the update is installed, I will then reinstall everything (including the GPU drivers). My guess is that the update process messes with the drivers and I'm curious if there might be a solution.

lorgar
Contributor

Re: Vive Pro audio quality

I was able to get major improvement using: https://www.amazon.com/gp/product/B00FR795WA/ref=oh_aui_detailpage_o02_s00?ie=UTF8&psc=1

 

In my case, the speakers were not getting enough power. It now sounds as good as the dulux audio strap....maybe a bit better. It also solved the issues I had with tracking.

 

I am not giving HTC a pass on this though. This is still crazy sloppy and should have been caught during testing.

MartinMarty
Architect

Re: Vive Pro audio quality

You've put that powered USB hub between the Vive Pro's link box and your computer?

 

I'll try anything.

Lestaticon
Pioneer

Re: Vive Pro audio quality

I tried the windows update 1803 again, after cleanly uninstalling all Vive software and drivers, doing the update, then reinstalling all, and I still get distorted audio through the USB pro driver output. If I select the hdmi output supplied by the nvidia driver, the audio clears up. If, however, I then reselect the usb outpout for the HMD, SteamVR may suddenly lose all tracking, lighthouses report as offline (even though on) and controllers power off.

The audio through my creative external DAC works fine. Is this a Vive driver issue with 1803 or a Windows 1803 audio issue? it seems like the audio driver for the Vive Pro's USB audio are generic Windows usb ones. They are supplied by Microsoft and they are dated 4/11/2018. Version #10.0.17134.1 (found in device manager).

I wonder if anyone still on Windows 1709 could check device manager and look at the "VIVE Pro Mutimedia Audio" (yes it is misspelled in device manager....) under "Sound, video and game controllers" and tell me what version they have?

 

 

AlexanderBr
Visitor

Re: Vive Pro audio quality

on Win10 1709 i have driver from 28/09/2017 #10.0.16299.15 and have issues with audio:

sometimes the microphone in the system (win) recording devices does not show the sound level, tried to turn on / off the button on the right earpiece, deleting vive audio driver and reinstal - it does not help. 
in the SteamVr and in the Discord, a suitable recording device is selected. It looks like a driver / firmware problem.