Vive Pro: Audio Problem (not the Bass one)

vidarwindir
Settler

Vive Pro: Audio Problem (not the Bass one)

Hello,

i just got the vive pro today but when i use the windows soundcheck to test the vie pro's sound everything sounds as it should but as soon as i open steam vr my sound changes to something "8 bit like audio".

Inside windows i've selected 16bit / 44,1 khz as audio quality but every other setting has the same problems.

 

Here's how it sounds like inside windows, then inside steam vr and then back in windows:
https://vocaroo.com/i/s1ASQWwyX1XY

Vive Staff

Re: Vive Pro: Audio Problem (not the Bass one)

@vidarwindir, when you go into SteamVR, what is your current primary audio device. Is it a USB driver or the Nvidia driver. Typically the Nvidia driver will work better in most cases. You can also go into window's "sound" and under devices, disable the USB driver device leaving only the Nvidia option. See if that helps. 

To reach Viveport's customer service team, email customerservice@viveport.com

To connect with a live support agent for hardware support, go to www.vive.com/support, click on "contact us" in the top righthand corner, and then opt to speak with a Live Chat agent

David R

Technical Specialist - San Francisco, CA; Monday-Friday

Click here to send me a PM

vidarwindir
Settler

Re: Vive Pro: Audio Problem (not the Bass one)

Thats all my options:

 

Unbenannt.PNG

 

 

Unbenannt2.PNG

Vive Staff

Re: Vive Pro: Audio Problem (not the Bass one)

@vidarwindir, is there not a Nvidia audio option for the Pro under "sounds"?  Have you hidden audio devices been the first screenshot and the second? It looks like you're using the USB driver which some report as being less reliable than the Nvidia driver. 

To reach Viveport's customer service team, email customerservice@viveport.com

To connect with a live support agent for hardware support, go to www.vive.com/support, click on "contact us" in the top righthand corner, and then opt to speak with a Live Chat agent

David R

Technical Specialist - San Francisco, CA; Monday-Friday

Click here to send me a PM

vidarwindir
Settler

Re: Vive Pro: Audio Problem (not the Bass one)

Hello,
i fixed it by reinstalled the graphics card driver. Everything working now. Thanks for the support! :)
Vive Staff

Re: Vive Pro: Audio Problem (not the Bass one)

@vidarwindir, thanks for posting your progress. Out of curiosity, did the graphics card update provide an an Nvidia audio option for the Vive?

To reach Viveport's customer service team, email customerservice@viveport.com

To connect with a live support agent for hardware support, go to www.vive.com/support, click on "contact us" in the top righthand corner, and then opt to speak with a Live Chat agent

David R

Technical Specialist - San Francisco, CA; Monday-Friday

Click here to send me a PM

vidarwindir
Settler

Re: Vive Pro: Audio Problem (not the Bass one)

Yes it did.

But there's more: When i exit steam vr and relaunch it, it won't detect the vive output anymore. I have to power cycle the link box to get it recognized again.

 

I also disabled the usb audio driver because if i launch the steamvr with the above mentioned problem, my ears get schocked. :D

Lestaticon
Pioneer

Re: Vive Pro: Audio Problem (not the Bass one)

At this stage after release of the Pro, this issue seems very consistant and easy to reproduce. (see all the previous audio issue threads)

In the past, it has been stated (Vive in general, so I am assuming it is the same for Pro) that the USB audio would be the better choice overall because it has better audio processing (better positional audio if I remember right). 

Since we keep getting pointed to using the HDMI/displayport audio as a workaround (note, it should be considered a workaround when the other option is broken), can you confirm that someone is actively working on an actual solution to the problem? 

 

The issue discribed here by @vidarwindir is shared by most who have the overall issues with the Vive Pro's audio; whether they realize it is another question. Due to the small user base, the even smaller amount of users who actually post feedback, and the even smaller amount who can pool all this feedback together and see the common threads, my worry is that this issue is being ignored or, worse, abandoned. Can you say, with certanty, that the audio troubles on the Pro is being worked on? 

vidarwindir
Settler

Re: Vive Pro: Audio Problem (not the Bass one)

I really hope that this issue won't be ignored. I removed the vive pros speakers and started using normal headphones with an usb soundcard on the usb-c port of the vive. Works flawless. (Anybody remeber the vive without das? lol)

I don't want to miss the picture quality of the vive pro but from sound i'd love to see/hear something like the samsung headset. :(

bmsimpson
Contributor

Re: Vive Pro: Audio Problem (not the Bass one)

With my Vive Pro, with any newer Nvidia driver other than 391.35 I have a terrible time getting the Vive Pro nvidia high definition audio option to show up. I have to troubleshoot audo, etc. to get it into the drop down list. Even then sometimes when it shows up I get no sound. I spent all day yesterday trying to get newer Nvidia drivers to work, with no luck. Finally gave up and reinstalled 391.35 and boom. The option is back and everything is normal. When I turn on Steam VR, I get the option every time. For anyone having this problem, you may want to try a driver rollback to that revision. Vive tech support, maybe there is a clue in that driver to what was changed to why everyone has this issue.

Highlighted
mandrokk
Settler

Re: Vive Pro: Audio Problem (not the Bass one)

I also have the problem with the Vive Pro HDMI device occasionally not showing up in SteamVR setting and occasionally having no sound output, even when the device shows up.

I discovered the followong workaround: If another HDMI audio device (e.g. a monitor) shows up in the SteamVR audio settings, selecting it makes the Vive Pro HDMI option appear and it can be selected. Annoying but better then restarting the whole shebang.

A proper fix by HTC, Valve or Nvidia would be greatly appreciated - as would be a short headsup, that this issue is being investigated.
Lestaticon
Pioneer

Re: Vive Pro: Audio Problem (not the Bass one)

Yep, @bmsimpson and @mandrokk, easily reproducable on my end every time I use the Vive Pro. Usually the displayport version of the audio is there (but with the notorious crackling audio) and the Nvidia version of the Pro audio is only there sometimes. I usually have to reboot the headset a couple times, or power down the linkbox, wait 30 sec, and power it back up. Since I can't use the displayport "Mutimedia" vive pro audio output without crackling audio, I have to fish around until I get the Nvidia one to show and resort to using that. 

I say resort, because it is just a workaround and not a solution. My understanding is that the Displayport/HDMI output is the one you would want to actually use for technical reasons (for full spacial audio?) - but cannot - because it's distorted with the crackling.