Sound is skewed and weird

Strahan
Settler

Sound is skewed and weird

Hi.  I had a Vive original version and it worked perfectly.  No issues in sound or video.  Tonight I bought the Vive Pro.  Plugged it up, ran the Vive Pro installer software.  I go in game and the video is great.  However, the audio was full of static.  I rebooted and reconnected everything.  Static not so bad anymore, but the sound is awful.  It's stuttery and sounds like it echos.  Very strange.  I turned on the mirror and my PC speakers are exhibiting the same weird sound so I doubt it's hardware.

 

Any idea what I should do?  When me and my friend get done playing I'm going to totally wipe out Steam and reinstall everything but figured I'd post awhile to get input in case that fails.  Thanks!

 

Here is a video of it: https://www.youtube.com/watch?v=9q-9YeLRr9A

Uploaded by Strahan740i on 2018-09-19.
Strahan
Settler

Re: Sound is skewed and weird

Well, I guess I should've waited to post until I did the nuke and pave.  After a complete uninstall of SteamVR / Steam followed by a reboot followed by reinstalling everything, sound is correct now :)

 

SHOOT.  It was fine all night and find today.  Then I heard Skype ringing and I went to the desk to get my headset.  Walking away with visor on, I tripped on the headset cable and yanked the cable out (headset cable) and BAM, the audio in the Vive went back to being like it was!  :'(

 

I tried rebooting but no avail.  I really don't want to try to the nuke and pave fix again as it took forever to get everything set back up and hundreds of gigs of games reinstalled.  I don't suppose anyone else has had this issue?

 

EDIT: OK, figured it out.  Again lol.  I was digging around on the Vive support section of their site and found an entry that referred to crackling in the speakers.  It said just unplug the USB cable from the linkbox.  So I unplugged it, waited for the tone to indicated devices dismounted then plugged it in.  I was pretty dubious about this.  Fired up VR, put on the headset and sound was perfect.  I'll be buggered lol

 

So I guess in the future if your sound is all messed up, just try unplugging and replugging the USB cable.  I assumed that toggling power did the same basic thing, as it also triggers the dismount tones but nope.  Nice.

Vive Staff

Re: Sound is skewed and weird

@Strahan, this sounds like it is related to whichever driver is powering the HMD's audio. You may wish to play around with disabling the USB audio device in favor of setting the Nvidia (I assume) audio device as the default device.

To reach Viveport's customer service team, email customerservice@viveport.com

To connect with a live support agent for hardware support, go to www.vive.com/support, click on "contact us" in the top righthand corner, and then opt to speak with a Live Chat agent

David R

Technical Specialist - San Francisco, CA; Monday-Friday

Click here to send me a PM

Strahan
Settler

Re: Sound is skewed and weird

Well, the problem with the sound was fixed by unplugging and reconnecting the USB cable from the linkbox.

 

That said...  now I have a new annoyance.  I just can't win with the audio on this thing.  Now I can fix the terrible sound, but sometimes I fire up SteamVR and I notice I don't hear birds chirping in Steam Home.  I fire up a game, and no audio.  I lift the HMD and check the Windows sound control panel, nothing is muted.  If I close SteamVR, unplug USB, plug back in, restart SteamVR the sound is back.

 

WHY is this being such a pain??  Spending another $800 on top of the initial $900 hurt enough, but to have the newer supposedly better unit be so annoyingly defective when it comes to audio is very disappointing.