Problems setting up a 8x8m room with 4 Lighthouses (2.0) and a Vive Pro

SOLVED
glossychops
Settler

Problems setting up a 8x8m room with 4 Lighthouses (2.0) and a Vive Pr...

Hi,

 

We are running the latest Steam VR Beta and have ensured that all firmware is up to date.

 

We are trying to setup an 8x8m space with 4 lighthouses (2.0) - one in each corner, with the PC and the Vive Wireless adapter in the middle of one of the sides pointing into the room (Wireless Adapter should be 6m range, but it seems to go just a bit further with a slight drop in quality).

 

We have powered on and connected the Link Box (without a headset connection) so that we can communicate with the Base Stations via Bluetooth, and have run the Base Station Bluetooth auto-detect tool to set the base stations to all be on different channels (1,2, 14 & 15)

 

The Base Stations are all showing white LEDS - so I guess they are syncing OK (do they even need to sync at 2.0 version still)?

 

We can see 4 lighthouses showing green in the Steam VR utility, but when we go to room setup, one of the Base Stations shows in completely the wrong location (almost in the middle of the room whilst the other three are showing about right in the corners). We have power cycled all the hardware and restarted Steam VR and the room setup numerous times but to no avail...

 

When I hover over the Base Station in the Steam VR utility it suggests that the base stations are too far apart - 10m instead of max 5.5m (but how can this be too far if the docs say that 4x Lighthouse 2.0's can do 10m x 10m room, making 14m on the diagonal?)

 

We then tried a 6m x 6m room with just 2 Base Stations and whenever we tried to do the room setup, it would default to a max 4m x 4m play space (green square in the room setup)?

 

What is the deal with running 4x lighthouses and the bigger room areas such as 8m x 8m - what do I need to do to get this to work?

 

Also, out of interest, do the new 2.0 Lighthouses need to "see" each other still to sync and hence is there a max distance apart that they need to be still because of this?

 

Some urgent advice would be gladly received as we have a big demo tomorrow.

 

Regards

 

Gary

Vive Staff
Solution

Re: Problems setting up a 8x8m room with 4 Lighthouses (2.0) and a Viv...

@glossychops,
I will send an advanced setup guide to the email address associated with your account. In short, 

  • You do not want to mount the station in the corners. The way you maximize your coverage area is to leverage the 150 horizontal FOV to produce a coverage map that doesn't waste the extra FOV. If you mount a basestation in a 90 degree corner, you'll waste ~40% of it's horizontal FOV.
  • The range for these basestations is ~5.5m (as reported by SteamVR) but there is actually alot of environmental 
  • I'm not sure why the basestation is reporting an incorrect location. It's likely due to a reflection, or a poor quality signal (due to range). You may wish to isolate and test the station in question at a work bench to see if it's tracking offset is due to environmental factors. It's possible that it's mechanical but the onboard diagnostics are pretty robust and would typically indicate a red LED if something were wrong.  
  • The systems are sync-on beam which means that they do not need to see each other - only the HMD/controllers need to be have line of sight to the basestations.
  • The height at which you mount the stations must be factored into your distance and range calculations. 
To reach Viveport's customer service team, email customerservice@viveport.com

To connect with a live support agent for hardware support, go to www.vive.com/support, click on "contact us" in the top righthand corner, and then opt to speak with a Live Chat agent

David R

Technical Specialist - San Francisco, CA; Monday-Friday

Click here to send me a PM

glossychops
Settler

Re: Problems setting up a 8x8m room with 4 Lighthouses (2.0) and a Viv...

Hi David,

 

Thanks so much for your help, running with the base stations at the centre point of each side of the square, rather than at the corners has allowed us to place the base stations 9.5m apart on each axis of the square, and then to setup a Chaperone boundary square of 8.5 m on each axis within it which is fully tracked for a single user.

 

I do have a couple of further resulting issues/queries, that perhaps you could advise on?

 

1. We are using the HTC Vive Wireless adapter and attaching the antenna on a pole about 6 inches below one of the Base Stations (ie on the middle of a side pointing into the play space. We find pretty good signal all the way to the far side of the play space (about 8m) and the display does not drop out. But, we do notice that when there is a lot of detail in view (a complex 2D frame to send?) that the VR visual becomes pretty pixelated. This seems to only occur when you are more than about 5m from the Antenna. I am guessing that this is because the Wireless Adapter must increase the video compression for when the signal strength drops to the headset when it is further away?

 

Are you able to tell me whether this is correct and a bit more about this? Is there anything that can be done to prevent the pixelating at the further distances (settings tweaking etc)?

 

2. We are seeing a lot of re-projections with the Unity App that we have developed when using this large room space and the Wireless Adapter (not sure if due to room size or wireless adapter?). I am pretty sure that we don’t see this when using 2 Base Stations in a 5m x 5m setup. I don’t understand why we are seeing the reprojections, though, as the advanced timing time slice is showing as about 6ms, so well under the 11ms needed to make 90 frames per sec. Can you explain what might be causing these high reprojection rates – is it the size of the room, wireless adapter performance, room environment (or something else)?

 

Anyway thanks for any advice you can offer.


Best Regards

 

Gary