PC crashes when I start SteamVR

mdinkov
Contributor

PC crashes when I start SteamVR

I’ve been trying to set-up my Vive system since last week with no luck. SteamVR finishes installing and I go through the room set-up successfully, but then my computer crashes when SteamVR starts up. When it crashes, I either get a black screen and it restarts or I get a blue screen with the error “WHEA_UNCORRECTABLE_ERROR”.

At first I thought that my GPU might be incompatable, so I spent $1050 on a GTX 1080ti and I still see the same issue! I tried reinstalling the Vive drivers (along with the NVIDIA drivers) with no luck. I’m using an i7-7820x processor on an ASUS TUF Mark 1 X299 board with 64GB of RAM. This system should be able to run the Vive EASILY.

I read through the forums and found out that people with ASUS motherboards were having a similar issue due to the USB ports. So I went to Best Buy and I spent more money on a PCIe USB3.0 card and I’m still seeing the issue...

I also made sure that my Windows is up to date. I’m running the 64-bit Windows Pro. If someone can help me out, I would be more than grateful.

Vive Staff

Re: PC crashes when I start SteamVR

     Hi @mdinkov,

     

     So, unfortunately this may be a difficult one to troubleshoot since it's a very uncommon error that can be highly specific to a single machine. We'll try out best to lend a hand. You may also want to contact SteamVR support who may be able to lend and hand in parallel. 

     

     First off, our team is curious about what will happen if you launch SteamVR with the Vive HMD unplugged. If it launches; what subsequently happens if you plug in the Vive (with SteamVR open). 

 

     Does your bluescreen list a crash dump location? If so, that dump file is by far our best lead. If you do have one, you can upload it to a service like pastebin for analysis. 

 

     Other ideas:

  • Go into your BIOS settings and ensure that you have disabled all overclocking utilities and options. While there, look into your power options and ensure that there is no power throttling at play.
    • In windows, ensure that you're using a "high preformance" power plan. 
  • What's your PSU wattage? One possible cause is that the GPU/CPU is underpowered.
  • You can try running a memory check to verify that it isn't a RAM issue. You can access a memory debugging tool by typing in "mdsched.exe" into the searchbar.
  • In your device manger, do you see any devices with a yellow "!" indicating an issue? (with and without the Vive plugged in)
  • Which version of windows are you running? 8 or 10? This error can apply to both. 
    • Due to meltdown/specter OEM patching; having the latest version of windows could possibly be a trigger for this on the CPU side. See here.
  • Have you tried bypassing the HDMI/USB from the linkbox and plugging the 3-in-1 directly into the computer? When doing this you must keep power connected through the linkbox.
  • Are you using any sort of display adapter to connect the Vive to the GPU?
To reach Viveport's customer service team, email customerservice@viveport.com

To connect with a live support agent for hardware support, go to www.vive.com/support, click on "contact us" in the top righthand corner, and then opt to speak with a Live Chat agent

David R

Technical Specialist - San Francisco, CA; Monday-Friday

Click here to send me a PM

Vive Staff

Re: PC crashes when I start SteamVR

Additional idea: @mdinkov, if you're able to start SteamVR with the HMD unplugged; hop into the settings page and under the "camera" tab try disabling the camera. That can cause issues in some cases. 

To reach Viveport's customer service team, email customerservice@viveport.com

To connect with a live support agent for hardware support, go to www.vive.com/support, click on "contact us" in the top righthand corner, and then opt to speak with a Live Chat agent

David R

Technical Specialist - San Francisco, CA; Monday-Friday

Click here to send me a PM

mdinkov
Contributor

Re: PC crashes when I start SteamVR

I got it to work by disabling SteamVR Home. I would still like to have a better fix just so I don't start crashing in the middle of games.

 

I was unable to attach the crash dump to pastebin, but here is some info that might help from it:

*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 124, {0, ffff830083307028, f2000000, 70005}

Probably caused by : GenuineIntel

Followup:     MachineOwner
---------
2: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

WHEA_UNCORRECTABLE_ERROR (124)
A fatal hardware error has occurred. Parameter 1 identifies the type of error
source that reported the error. Parameter 2 holds the address of the
WHEA_ERROR_RECORD structure that describes the error conditon.
Arguments:
Arg1: 0000000000000000, Machine Check Exception
Arg2: ffff830083307028, Address of the WHEA_ERROR_RECORD structure.
Arg3: 00000000f2000000, High order 32-bits of the MCi_STATUS value.
Arg4: 0000000000070005, Low order 32-bits of the MCi_STATUS value.

Debugging Details:
------------------


KEY_VALUES_STRING: 1


TIMELINE_ANALYSIS: 1


DUMP_CLASS: 1

DUMP_QUALIFIER: 400

BUILD_VERSION_STRING:  10.0.16299.192 (WinBuild.160101.0800)

SYSTEM_MANUFACTURER:  System manufacturer

SYSTEM_PRODUCT_NAME:  System Product Name

SYSTEM_SKU:  SKU

SYSTEM_VERSION:  System Version

BIOS_VENDOR:  American Megatrends Inc.

BIOS_VERSION:  0702

BIOS_DATE:  08/08/2017

BASEBOARD_MANUFACTURER:  ASUSTeK COMPUTER INC.

BASEBOARD_PRODUCT:  TUF X299 MARK 1

BASEBOARD_VERSION:  Rev 1.xx

DUMP_TYPE:  2

BUGCHECK_P1: 0

BUGCHECK_P2: ffff830083307028

BUGCHECK_P3: f2000000

BUGCHECK_P4: 70005

BUGCHECK_STR:  0x124_GenuineIntel

CPU_COUNT: 10

CPU_MHZ: e10

CPU_VENDOR:  GenuineIntel

CPU_FAMILY: 6

CPU_MODEL: 55

CPU_STEPPING: 4

CPU_MICROCODE: 6,55,4,0 (F,M,S,R)  SIG: 2000026'00000000 (cache) 2000026'00000000 (init)

BLACKBOXBSD: 1 (!blackboxbsd)


BLACKBOXPNP: 1 (!blackboxpnp)


CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT

PROCESS_NAME:  steamtours.

CURRENT_IRQL:  f

ANALYSIS_SESSION_HOST:  DESKTOP-KQ3220J

ANALYSIS_SESSION_TIME:  02-08-2018 21:00:48.0146

ANALYSIS_VERSION: 10.0.17074.1002 amd64fre

STACK_TEXT:  
ffffe600`c726bde8 fffff801`bf525f1f : 00000000`00000124 00000000`00000000 ffff8300`83307028 00000000`f2000000 : nt!KeBugCheckEx
ffffe600`c726bdf0 fffff804`7eaa148a : ffff8300`83307028 ffff8300`7ef814e0 ffff8300`7ef814e0 ffff8300`7ef814e0 : hal!HalBugCheckSystem+0xcf
ffffe600`c726be30 fffff801`bee9aab1 : ffff8300`83307028 00000000`00000000 ffff8300`7ef814e0 ffff8300`7ef814e0 : PSHED!PshedBugCheckSystem+0xa
ffffe600`c726be60 fffff801`bf526460 : 00000000`00000728 00000000`00000002 00000000`00000000 00000000`00000000 : nt!WheaReportHwError+0x261
ffffe600`c726bec0 fffff801`bf5267c0 : 00000000`00000010 00000000`00000002 ffffe600`c726c068 00000000`00000002 : hal!HalpMcaReportError+0x50
ffffe600`c726c010 fffff801`bf5266ae : ffff8300`7ef82160 00000000`00000001 00000000`00000000 00000000`00000000 : hal!HalpMceHandlerCore+0xe0
ffffe600`c726c060 fffff801`bf5268f2 : 00000000`00000010 00000000`00000001 00000000`00000000 00000000`00000000 : hal!HalpMceHandler+0xda
ffffe600`c726c0a0 fffff801`bf526a80 : ffff8300`7ef82160 ffffe600`c726c2d0 00000000`00000000 00000000`00000000 : hal!HalpMceHandlerWithRendezvous+0xce
ffffe600`c726c0d0 fffff801`bed9aa3b : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : hal!HalHandleMcheck+0x40
ffffe600`c726c100 fffff801`bed9a6bd : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KxMcheckAbort+0x7b
ffffe600`c726c240 00007ff9`81f315ab : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiMcheckAbort+0x47d
00000081`310d7710 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x00007ff9`81f315ab


THREAD_SHA1_HASH_MOD_FUNC:  a23b7d765df95ae34e5a10fad949ea2e4c0373b0

THREAD_SHA1_HASH_MOD_FUNC_OFFSET:  9d4877dc8bbb2df07ac176134a97f279382d2646

THREAD_SHA1_HASH_MOD:  156f1337245e21f523efe2d6f6d05bb3ab59ca82

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: GenuineIntel

IMAGE_NAME:  GenuineIntel

DEBUG_FLR_IMAGE_TIMESTAMP:  0

STACK_COMMAND:  .thread ; .cxr ; kb

FAILURE_BUCKET_ID:  0x124_GenuineIntel_PROCESSOR_MAE

BUCKET_ID:  0x124_GenuineIntel_PROCESSOR_MAE

PRIMARY_PROBLEM_CLASS:  0x124_GenuineIntel_PROCESSOR_MAE

TARGET_TIME:  2018-02-08T00:25:33.000Z

OSBUILD:  16299

OSSERVICEPACK:  192

SERVICEPACK_NUMBER: 0

OS_REVISION: 0

SUITE_MASK:  272

PRODUCT_TYPE:  1

OSPLATFORM_TYPE:  x64

OSNAME:  Windows 10

OSEDITION:  Windows 10 WinNt TerminalServer SingleUserTS

OS_LOCALE:  

USER_LCID:  0

OSBUILD_TIMESTAMP:  2018-01-01 06:07:05

BUILDDATESTAMP_STR:  160101.0800

BUILDLAB_STR:  WinBuild

BUILDOSVER_STR:  10.0.16299.192

ANALYSIS_SESSION_ELAPSED_TIME:  38b

ANALYSIS_SOURCE:  KM

FAILURE_ID_HASH_STRING:  km:0x124_genuineintel_processor_mae

FAILURE_ID_HASH:  {7c95de0c-286c-8226-45c2-422b4de101d6}

Followup:     MachineOwner

 

Answer to Questions:

  • Go into your BIOS settings and ensure that you have disabled all overclocking utilities and options. While there, look into your power options and ensure that there is no power throttling at play
    I believe my board is overclocking my CPU slightly by default. I'm not sure what settings to change to disable it. :\ 
    • In windows, ensure that you're using a "high preformance" power plan.
      I just checked and it is already on High Performance.
  • What's your PSU wattage? One possible cause is that the GPU/CPU is underpowered.
    1300 watts
  • You can try running a memory check to verify that it isn't a RAM issue. You can access a memory debugging tool by typing in "mdsched.exe" into the searchbar.
    I will do that and let you know how it goes.
  • In your device manger, do you see any devices with a yellow "!" indicating an issue? (with and without the Vive plugged in)
    Nope
  • Which version of windows are you running? 8 or 10? This error can apply to both.
    10 Pro 
    • Due to meltdown/specter OEM patching; having the latest version of windows could possibly be a trigger for this on the CPU side. See here.
      Good to know... I will also try rolling back Windows.
  • Have you tried bypassing the HDMI/USB from the linkbox and plugging the 3-in-1 directly into the computer? When doing this you must keep power connected through the linkbox.
    I have not tried this, but I'll give it a whirl.
  • Are you using any sort of display adapter to connect the Vive to the GPU?
    Nope, straight into the HDMI slot of the graphics card.
dorianv
Visitor

Re: PC crashes when I start SteamVR

I'm having the exact same issue on 2 brand new PC's with the same motherboard. DigitalStorm is the PC manufacturer we ordered from. We went thru neary 16 hours of trouble shooting with them trying to find what was causing the crash, but wound up RMA'ing both machines. They sent 2 NEW brand-new pc's and guess what ... both blue screen opening steamVR. 

 

Has there been any resolution to this? I'm getting desperate over here and DS will not replace them for software problems.

 

I've tried with both Vive and Vive Pro ... wired and wireless ... HMD on and HMD off. Crash every time.

 

Please help.

edenedeneden
Visitor

Re: PC crashes when I start SteamVR

THANK GOD I AM NOT THE ONLY ONE WITH THIS PROBLEM!

I have the exact same problem with a brandnew Hyrican Striker 6110.
I got BSODs all the time with
WHEA_UNCORRECTABLE_ERROR.
So I went to the store and got a new same Hyrican. Same problem again!
PLEASE help!

Did anyone find a solution yet?
Highlighted
Vive Staff

Re: PC crashes when I start SteamVR

@edenedeneden 

 

A significant number of solutions were proposed earlier in the thread. Did you try any or all of them? What was the result of your testing?

Thank you,

-John C

"Welcome to the desert of the real."

If your base station has a Fault 02/03 error or a red light or both, the ONLY solution is to contact our support on vive.com and set up an RMA. There is no user fix for this issue.

Vive Care Operating Hours: 9am to 6pm PST, M-F
Fernander
Contributor

Re: PC crashes when I start SteamVR

I've had my vive for the last 4-5months or so and have run every game on it at max as I have a high-end VR ready gaming desktop and recently I have been having the same problems. it's weird because this never came up for me and suddenly when I am playing mid game my whole computer crashes. like my computers CPU and GPU suddenly overload. this problem started happening today, after playing for about 2 hours my computer crashes and i don't really think much of it but for the last 30 min or so 3min after loading up a game i crash. i have tried all the tips vive posted in the thread, tried making sure every app that i was not going to use was closed to maybe loosen on the load my computer should not have to take. in game, my computer runs at around 30% so i dont understand what is happening.

Fernander
Contributor

Re: PC crashes when I start SteamVR

Update

while trying to troubleshoot my vive it crashed my computer without the application even being open.

 

this is getting absurd. i don't know if it has to do with a recent "hotfix" that i might have missed even though i am up to date on everything or my computer just doesnt like the application anymore

matob
Visitor

Re: PC crashes when I start SteamVR

I dont know but my steam crash too.  i google some info from website not found solution

Vive Staff

Re: PC crashes when I start SteamVR

@matob  @mdinkov  @Fernander  @edenedeneden  @dorianv 

A new Nvidia update came out recently and there have been some reports of issues with it. Have you tried rolling back to the previous update?

Thank you,

-John C

"Welcome to the desert of the real."

If your base station has a Fault 02/03 error or a red light or both, the ONLY solution is to contact our support on vive.com and set up an RMA. There is no user fix for this issue.

Vive Care Operating Hours: 9am to 6pm PST, M-F
essebo
Visitor

Re: PC crashes when I start SteamVR

I have the same unsolved issue with blue/black screeen when starting Steam VR, but I also have made some additional observations which might shed some light on the problem.

 

First of all, I use old (2018) Nvidia drivers, so I do not think it is caused by the latest update.

Second, when installing Vive I postponed reboot after installing the software and both the headset and Steam VR was working until I rebooted my PC, so it might be a configuration issue as the finalization of the install (i e the reboot) seems to have triggered the problem.

Third, I've been able to provoke a blackscreen without even trying to start Steam VR.  I got a blackscreen/reboot just by turning the headset off and restarting it. The PC dies the instant the LED on the headset turns green.

 

Best regards

/e

 

 

 

 

Salvajje
Contributor

Re: PC crashes when I start SteamVR

Hi Guys,

 

I recently built a brand new computer.

AMD ryzen 5 2600x

Ge Force RTX 2070

and everything else needed

Bought a HTC vive

Played for about 2 days without issues, i have it running on my tv etc. Just like all of you.

I played pavlov with some buddies for about 4 hours straight

later that week i downloaded, Rec room.

later that week as i was trying to play rec room it would kick me out of the game or freeze. Then i went into a game i know works which was pavlov and then BAM blue screen so then i troubleshot some stuff and now it would only let me play about 1/2 in which ever game. Then i troubleshot some more and the same (when i say trouble shot i mean making sure i reinstall and swtich the USB ports etc.)

 

Recently i was downloading some stuff for my VR home and again it gave me blue screen error code was:

System service exception

what failed: nvlddmkm.sys

wondering if anyone found a fix? or they have made some headway on this?

 

 

 

 

Vive Staff

Re: PC crashes when I start SteamVR

@Salvajje - BSOD's can be tricky without the complete stop code (the error code it lists) but crashes related to nvlddmkm.sys are almost always related to Nvidia drivers. It usually means a driver is corrupted. You should try to do a complete "clean" install of the driver (either via Nvidia's installer -> advanced setup -> preform clean install) or by using DDU (Display Driver Uninstaller). Try installing the latest driver again, if it doesn't work - try a few versions back and see if there's a difference. If you Google around, you'll see that sometimes people can only solve this issue with a clean install - it can be a deeply embedded corruption. 

 

What does Window's Event viewer list under critical events? It should capture alot more info about the issue. You'd probably want to check out the event viewer and based off what you see there create a support ticket with Nvidia.

 

This could also be related to the GPU overheating or the PSU not delivering enough juice. 

To reach Viveport's customer service team, email customerservice@viveport.com

To connect with a live support agent for hardware support, go to www.vive.com/support, click on "contact us" in the top righthand corner, and then opt to speak with a Live Chat agent

David R

Technical Specialist - San Francisco, CA; Monday-Friday

Click here to send me a PM

Salvajje
Contributor

Re: PC crashes when I start SteamVR

Thanks for the info! @VibrantNebula 

 

So to give you an update on this i took it into the place where i bought all my parts for them to inspect. I had this feeling it was not a software issue. The reason why i had this feeling is because all the parts are less then 15 days old (since time i bought them) and i had done most of the re installing and rolling back that i could. Turns out my brand new CPU was failing, droping cores like no tomorrow. They replaced it and i played a lot last night with no issues. I will keep testing it and keep you guys in the loop.