Lighthouse does not power on after firmware update

Beauregard
Settler

Lighthouse does not power on after firmware update

Hi

I have updated the firmware of my controllers and both lighthouses. As result, one of them did not power on after the update. I searched the forums and tried all suggested measures such as replacing the firmware etc. nothing works.

What I don't understand: Why is there not an application which allows simply to reset the firmware via USB cable? Why is not possible simply to reinstall again the newest firmware?

 

What should I do now?

 

best regards

Vive Staff

Re: Lighthouse does not power on after firmware update

@Beauregard

 

Hi Beauregard,

Are you getting a fault 02 or fault 03 error? Any flashing red lights? If the base station simply won't power on at all, please check the power adapter first and see if that's where the fault lies. If it is a fault 02 or fault 03 error, please contact our Live Chat support on our website to set up a repair.

Thank you,

-John C

"Welcome to the desert of the real."

If your base station has a Fault 02/03 error or a red light or both, the ONLY solution is to contact our support on vive.com and set up an RMA. There is no user fix for this issue.

Vive Care Operating Hours: 9am to 6pm PST, M-F
Hersonrock
Explorer

Re: Lighthouse does not power on after firmware update

This should be it ( Copied from Steam Support : https://steamcommunity.com/app/358720/discussions/0/385428458171928063/ )

"

The fix has worked successfully for several users, so we shipped the required files in the latest beta. You can find the files under your SteamVR install directory. The easiest way to get there is to right click on SteamVR in Steam, select Properties, click on the Local Files tab and Browse Local Files... Once there the firmware files live in: tools\lighthouse\firmware\lighthouse_tx\archive\htc_2.0 You will need two files: * lighthouse_tx_htc_2_0-calibration-rescue-244.bin * lighthouse_tx_htc_2_0-244-2016-03-12.bin WARNING: You should not attempt this fix unless your base stations are really broken. While it *should* be harmless, there is a non-zero chance it could make things worse. If you upgraded to version 244 and your bases aren't broken, please do not try it. This fix also applies only to HTC base stations, it will not work with older VDK1/Robin or the red laser Batman units. The procedure is much like upgrading manually, but you do it twice, once with the fix-up firmware which will try to fix the base station, then once it has completed the fix, again with the current latest firmware.

1. With the base station unpowered, connect via a micro-B USB cable to your PC.

2. Hold the mode button down and plug in the power lead.

3. You can release the button once it enumerates as a USB mass storage device.

4. The drive will be called “CRP_DISABLED” and contain one file “firmware.bin”, delete that file.

5. Copy over onto the drive the “lighthouse_tx_htc_2_0-calibration-rescue-244.bin” file. 6. Once the copy is complete, pull out the power lead.

7. Wait a few seconds then plug in the power again. Be sure not to press the mode button while powering it up this time.

8. In a couple of seconds it should rapidly flash green or red. Green means it succeeded.

9. If it is flashing red that means it couldn’t automatically fix it and I’ll need to look at the unit to work out why. 10. Unplug the power again.

11. Repeat steps 1 thru 7 but using the “lighthouse_tx_htc_2_0-244-2016-03-12.bin” firmware file instead of the rescue one.

12. The base should now be working again, confirm by setting its mode to "A" and tracking with it alone (the other base turned off). Once it is confirmed working you can add back the other base. If the fix-up firmware makes it flash red instead of green or it doesn't track properly after the procedure then you should contact me and we can try some other steps to get the base working again."

Beauregard
Settler

Re: Lighthouse does not power on after firmware update

thanks for the feedback.

All these suggestions I tried without success. The lighthouse has now been sent to HTV Vive and I am waiting for a new one.

Beauregard
Settler

Re: Lighthouse does not power on after firmware update

Update: HTC sent again a not working lighthouse.

I had to send it a second time to their repair center and got it yesterday. Guess what? The lighthouse shows still "Manufactorer Error" and does not work (!). Worst support ever, seems HTC has no interest to repair hardware

aost
New Arrival

Re: Lighthouse does not power on after firmware update

hello Beauregard

just to make sure connect the lighthouse to your pc and delete the firmware file and use this one(up to date):

https://drive.google.com/open?id=1IMJTi_zJCTodrYBLDFdwCk6cnGqOvAH9

 

tell me if it works ^^

 

Beauregard
Settler

Re: Lighthouse does not power on after firmware update

after 2.5 monhts and sending in my lighthouse 3 times, I finally got a lighthouse working.

However, HTC again did not manage to send a lighthouse with the current firmware, I have no idea who or what is working the support centers. I will not updated the firmware, because this started all the troubles.

Considering this trouble and that support questions never got answered about the partly chaotic settings/gui, I would not buy again a HTC Vive.

Vive Staff

Re: Lighthouse does not power on after firmware update

@Beauregard
I responded to you in this thread: http://community.viveport.com/t5/Technical-Support/Worst-Support-ever/m-p/21935?__woopraid=RhMt4mvMW...

Please avoid posting duplicate posts in different threads as it will trigger the spam filter.

Thank you,

-John C

"Welcome to the desert of the real."

If your base station has a Fault 02/03 error or a red light or both, the ONLY solution is to contact our support on vive.com and set up an RMA. There is no user fix for this issue.

Vive Care Operating Hours: 9am to 6pm PST, M-F
EhrenFox
Contributor

Re: Lighthouse does not power on after firmware update


@aost wrote:

hello Beauregard

just to make sure connect the lighthouse to your pc and delete the firmware file and use this one(up to date):

https://drive.google.com/open?id=1IMJTi_zJCTodrYBLDFdwCk6cnGqOvAH9

 

tell me if it works ^^

 


This file fixed my lighthouses and allowed me to update firmware successfully (well I connected via usb this time while updating)

Thanks!

Vive Staff

Re: Lighthouse does not power on after firmware update

@EhrenFox

 

Please don't bump old threads. Also, unfortunately, that file won't fix your base station. The underlying issue still exists, so all that's happened is delaying the inevitable hardware failure. If you're under warranty, I recommend getting a warranty RMA ASAP. If not, that file will help for a period of time, after which, expect the device to fail completely.

Thank you,

-John C

"Welcome to the desert of the real."

If your base station has a Fault 02/03 error or a red light or both, the ONLY solution is to contact our support on vive.com and set up an RMA. There is no user fix for this issue.

Vive Care Operating Hours: 9am to 6pm PST, M-F
EhrenFox
Contributor

Re: Lighthouse does not power on after firmware update


@Synthesis wrote:

@EhrenFox

 

Please don't bump old threads. Also, unfortunately, that file won't fix your base station. The underlying issue still exists, so all that's happened is delaying the inevitable hardware failure. If you're under warranty, I recommend getting a warranty RMA ASAP. If not, that file will help for a period of time, after which, expect the device to fail completely.

Thank you,

-John C


Sorry, this was the only working solution I could find through google so I felt like I had to thank the person. Is it really going to fail? I only just ordered my Vive new from the vive website and recieved it yesterday. My base stations power on fine until I tried to update the firmware, after which they just killed themselves and I had to go through and try all of these fixes. (the officially provided ones just left me with a green flashing light but no connection).

Are they really going to end up dying even though I was able to update the firmware successfully after using this persons file to restore them? What's wrong with both my base stations hardware that causes this?

Highlighted
tonyremontana
Contributor

Re: Lighthouse does not power on after firmware update

I was surprised but this really helped me (steps with 244-rescue and then 244) ! The station now works. Thank you for saving me money and time!

Vive Staff

Re: Lighthouse does not power on after firmware update

@tonyremontana,

 

Just want to reiterate that there is no "recovery" method for basestations. The older firmware from Valve doesn't contain the error checking / self-diagnostic tools that are contained in more recent firmware images. Your basestation could actually be non-functional and just lack the error reporting to have the proper LED and SteamVR indicator.

 

You can tell if a basestation is truly working by ensuring that the station in question is the only station that's powered on, and attempting to use it in single basestation mode by flipping it over to channel A and seeing if tracking works well when it's based off the single station. 

To reach Viveport's customer service team, email customerservice@viveport.com

To connect with a live support agent for hardware support, go to www.vive.com/support, click on "contact us" in the top righthand corner, and then opt to speak with a Live Chat agent

David R

Technical Specialist - San Francisco, CA; Monday-Friday

Click here to send me a PM

tonyremontana
Contributor

Re: Lighthouse does not power on after firmware update

Hi again,

 

you're right. Despite the fact that I restored it to 244 and the station started working (I mean green light, red lattice of leds as usual) I get no tracking in A mode. Steam VR says that the station works well and is tracked but headset does not work with station's A mode at all. Tried to update firmaware to the newest suggested by Steam VR but get blinking red again. What should I do?