Community Announcements

Need help with Viveport? Read this FAQ for information.

Head unit goes black in game

SOLVED
Settler

Head unit goes black in game

Hi all, 

Just got a brand new vive. Got it setup, firmware updates were sucessful.  Things seemed to be running fine (finicky, but working).  All of a sudden I started having an issue where in while in the game, the display goes black.  The game will still be running on the computer, but I loose connectivity to the head unit.

 

I've checked the connection on the head unit itself by lifting the cover.  All connections are tight from head unit, to the box, to the computer.  

1 ACCEPTED SOLUTION

Accepted Solutions
Vive Staff
Vive Staff

Re: Head unit goes black in game

[ Edited ]

RickB wrote:

Hi all, 

Just got a brand new vive. Got it setup, firmware updates were sucessful.  Things seemed to be running fine (finicky, but working).  All of a sudden I started having an issue where in while in the game, the display goes black.  The game will still be running on the computer, but I loose connectivity to the head unit.

 

I've checked the connection on the head unit itself by lifting the cover.  All connections are tight from head unit, to the box, to the computer.  


Switch to mini-DP connection for the Vive interface box to laptop if you have the appropriate cable and report back if the issue is resolved. If you still have in-game audio, then it seems like an issue with the laptop and direct mode. Also install NVIDIA GeFORCE Experience software and check again that your drivers are updated to the latest. The latest version for your config should be 378.92 (updated on 3/20). 

15 REPLIES
Settler

Re: Head unit goes black in game

Does the audio stop as well? If yes then it could be a faulty HDMI cable.

Settler

Re: Head unit goes black in game

[ Edited ]

Hmmm, I don't think anything goes wrong with the audio.  I'll double check next time I play though. I've noticed that this seems to be happening in all games.  At some point, the display will go black no matter which game I'm playing.  

Architect

Re: Head unit goes black in game

Any reflective surfaces around? I have a large tv and when i get close to that i go black. just take a step back. also  mirrors, windows all cause the same issue. 

how do you restore your picture do you have to reboot or does it just come back

Se7enVR
-Is it Real or Just VR? not a question just a Signature
Contributor

Re: Head unit goes black in game

look in you vserver.txt log and check if there is an entry 'entering standby' at the same time when the headset goes black in a game, followed a few seconds later by a 'leaving standby' entry when the headset turns back on.  The iRacing forums have people with this problem and the common thing seems to be the headset going into power saving mode while it is being worn.  It goes into power saving mode, then immediatly wakes back up again from the headset movement.  It shouldn't be going into power save mode in the first place.  You get an entry in the vserver.txt log when the headset does this.  

Settler

Re: Head unit goes black in game

[ Edited ]

Se7en11 wrote:

Any reflective surfaces around? I have a large tv and when i get close to that i go black. just take a step back. also  mirrors, windows all cause the same issue. 

how do you restore your picture do you have to reboot or does it just come back


HI... There is a mirror on the wall.  About 2'6" by 3'6"
Off the top of my head I can't say with any certainty that I was facing the mirror when it happen.  
There IS the possibility that the lighthouse beams COULD be reflecting off this surface.  Is that where you going with this?

 

To restore, I have to completely unplug the little box that sits between all the cabling and reboot my computer.

 

Thank you very much for your help! Smiley Happy

 

Settler

Re: Head unit goes black in game

[ Edited ]

Marcus wrote:

look in you vserver.txt log and check if there is an entry 'entering standby' at the same time when the headset goes black in a game, followed a few seconds later by a 'leaving standby' entry when the headset turns back on.  The iRacing forums have people with this problem and the common thing seems to be the headset going into power saving mode while it is being worn.  It goes into power saving mode, then immediatly wakes back up again from the headset movement.  It shouldn't be going into power save mode in the first place.  You get an entry in the vserver.txt log when the headset does this.  


Ok, next time I fire up my computer that this runs on, I will check the log.  I can say that the headset never seems to come out of any type of standby.  Just goes black and stays there. 

 

Thank you very much for your help! Smiley Happy

Vive Staff

Re: Head unit goes black in game

Hi Rick,

Please check if you have both your HDMI (HMD and screen)  connected to the same graphics card.  
Also check if your graphics card driver is up to date.  

 

Thanks. 

 

Cory C.  

Settler

Re: Head unit goes black in game


CoryCheng wrote:

Hi Rick,

Please check if you have both your HDMI (HMD and screen)  connected to the same graphics card.  
Also check if your graphics card driver is up to date.  

 

Thanks. 

 

Cory C.  


Hi Cory thanks for the reply, my computer is an Asus G752VS laptop.

  • Intel® Core i7 6700HQ Processor
  • NVIDIA GeForce 1070
  • 1 HDMI
  • 1 Mini Display Port

 All drivers for the laptop seem to be up to date. 

Vive Staff

Re: Head unit goes black in game

@RickB
Can you run a SteamVR report log and PM me?
I'd like to take a look at it.

Thanks,
-John C

"Welcome to the desert of the real."
Highlighted
Settler

Re: Head unit goes black in game


Synthesis wrote:

@RickB
Can you run a SteamVR report log and PM me?
I'd like to take a look at it.

Thanks,
-John C


Sure you bet... I still have not been back on my VR system.  Vacation days.  Do I run the report from the SteamVR software itself?

Vive Staff

Re: Head unit goes black in game

Yes,

Just open SteamVR and click on the SteamVR drop down and select "Create System Report"

Thanks,

-John C

"Welcome to the desert of the real."
Settler

Re: Head unit goes black in game

Hi Synthesis...

I tried to send you the contents of the report via a PM, but the report was too long. Guess a PM can only be 60,000 chars.  Do you have an email address you can PM me and I'll send you the file that way?

 

Vive Staff
Vive Staff

Re: Head unit goes black in game

[ Edited ]

RickB wrote:

Hi all, 

Just got a brand new vive. Got it setup, firmware updates were sucessful.  Things seemed to be running fine (finicky, but working).  All of a sudden I started having an issue where in while in the game, the display goes black.  The game will still be running on the computer, but I loose connectivity to the head unit.

 

I've checked the connection on the head unit itself by lifting the cover.  All connections are tight from head unit, to the box, to the computer.  


Switch to mini-DP connection for the Vive interface box to laptop if you have the appropriate cable and report back if the issue is resolved. If you still have in-game audio, then it seems like an issue with the laptop and direct mode. Also install NVIDIA GeFORCE Experience software and check again that your drivers are updated to the latest. The latest version for your config should be 378.92 (updated on 3/20). 

Settler

Re: Head unit goes black in game


Jad wrote:

RickB wrote:

Hi all, 

Just got a brand new vive. Got it setup, firmware updates were sucessful.  Things seemed to be running fine (finicky, but working).  All of a sudden I started having an issue where in while in the game, the display goes black.  The game will still be running on the computer, but I loose connectivity to the head unit.

 

I've checked the connection on the head unit itself by lifting the cover.  All connections are tight from head unit, to the box, to the computer.  


Switch to mini-DP connection for the Vive interface box to laptop if you have the appropriate cable and report back if the issue is resolved. If you still have in-game audio, then it seems like an issue with the laptop and direct mode. Also install NVDIDA GeFORCE Experience software and check again that your drivers are updated to the latest. The latest version for your config should be 378.92 (updated on 3/20). 


Hi Jad...

I do have the GeForce software on the laptop, drivers are updated to latest.
I swapped to mini-DP and that seemed to work! I have been able to play both theBlu and Arizona Sunshine this morning and everything seems to be running great!

 

Thank you all so much for your assistance. Greatly appreciated!