Disable headset sleep/standby

MagNet
New Arrival

Disable headset sleep/standby

Hi,

 

I am using the vive system to develop an interactive installation piece in real life as the tracking is amazing.

 

I am however getting problems with the HMD going to sleep after a few minutes since it's not used and then I lose the controllers as well.

 

Is there a way to disable the standby mode in the HMD?

Secondly, but I might start another topic for this, can rendering to the HMD be disabled while it is on, to save system resources.

 

Thank you

Vive Staff

Re: Disable headset sleep/standby

Hi MagNet,

There isn't a way to do it in settings currently, but what you can do is block the sensor between the lenses (It's right above the bridge of the nose on the HMD) with something. Preferrably something like a sticky note or a soft piece of microfibre cloth.

That should prevent it from going into standby mode while you're working.

Cheers,
-John C

 

 

"Welcome to the desert of the real."
Constantin Suman
New Arrival

Re: Disable headset sleep/standby

https://image.prntscr.com/image/GrvjZB_LRa6klQbcx5PaTQ.png
Putting a sticky note on the head cushion to cover the sensor works (the HMD doesn't go to sleep), but it also covers the lenses, so you can't use the HMD.
Sticking something directly on the sensor doesn't work (the HMD goes to sleep).
One has to make some tests to be able to cover the sensor to achieve the Allways_On state of the HMD, and also be able to wear it when required, without having to peel off the sensor cover.

T4n00Ki
New Arrival

Re: Disable headset sleep/standby

Hi! I was wondering the same thing for a vr interactive exhibit.
Did covering the HMD sensor end up working?
Thanks!
Vive Staff

Re: Disable headset sleep/standby

@T4n00Ki

 

It usually does the trick!


Thanks,

-John C

"Welcome to the desert of the real."
SWAT Strachan
Settler

Re: Disable headset sleep/standby

First off, apologies for digging up an older thread, but I'm having a similar issue with my Vive, except in my case the headset will go in to standby mode whilst I'm still wearing it. I will be in the middle of a mission in Elite Dangerous and suddenly the display will just go black, and the SteamVR app states that the headset is in stanby mode.

 

I have tried covering over the sensor in the Vive but that has made no difference, it still cuts out at random (whether or not it is being worn at the time) but does come back if I make a movement in any direction. This issue only started a couple of days ago, and hasn't happened once in the previous 11 months that I've been using it. Could it be a SteamVR update that's causing the issue as I can't find anything in the settings to disable standby mode.

Highlighted
nyankas
New Arrival

Re: Disable headset sleep/standby

I seem to have the same problem since today. I guess (hope) it's a software issue. I've tried the SteamVR beta as well as the stable version but it makes no difference. Sticking something on the sensor doesn't do anything as well.

Rodan65
New Arrival

Re: Disable headset sleep/standby

I'm having the exact same issue, also in Elite Dangerous but it does it in other software too, I hate to think what watching a movie would be llike now.. I've tried unchecking the 'pause rending rendenering while the headset is idle' option in the developer section of Steam VR beta but the problem is still happening. Was perfect before the last Steam VR update

Weed
Contributor

Re: Disable headset sleep/standby

**Headset goes into standby mode in 10-20 seconds** First I am relieved that I have found others having this problem. I started experiencing this issue first off about 5 days ago in elite dangerous. The problem was not present at all before that although I’ve only owned the Vive for a month. I have tried other games that are seated play and they have the same problem with the headset going into standby after 10-20 seconds of no movement. Audio is still working. I did chat support with HTC and they said that the vive isn’t the problem because I need to be in the play area. I tried moving inside the play area instead of sitting just outside of it but the same problem persists. I’ve now reached out to steam but I’m concerned how long it will take to hear anything back from them. Tried many troubleshooting steps and nothing fixes this. Graphics card up to date, USB ports changed, uninstalled and reinstalled steam VR and USB drivers, reset room scale, tape over the lense in the headset, all firmware up to date on lighthouses, power settings on high performance, direct mode turned on, steam beta on or off and none of this changes anything regarding this problem. I have only had the vive for a few weeks. I am now at the point where I can’t use it and enjoy it. Please post if anyone finds a solution and I will do the same.
BrokenPoet
Visitor

Re: Disable headset sleep/standby

I started having the same problem in Elite Dangerous (via Steam) a few days ago.  The Vive goes into standby for 2-5 seconds at random intervals during gameplay.

Weed
Contributor

Re: Disable headset sleep/standby

If it’s like what I am experiencing then the reason it goes black for 2-5 seconds is because you move the headset and wake it up. It takes that long to display video again. Next time it happens try keeping the headset still. I’ll bet it stays dark. The icon in steam vr will say the hmd is in standby.
BuddyMocha
New Arrival

Re: Disable headset sleep/standby

This has just started to happen to me as well, when I'm playing games in the SteamVR game theater the Vive turns off (goes into standby mode as the app says) if my head isn't constantly moving.
DaVinster
Contributor

Re: Disable headset sleep/standby

This just started happening to me too when I tried to move my Vive to a new PC and a fresh build (Win 10 x64 Ent).  This seems to also be effecting my ability to install the Vive and SteamVR software as SteamVR can't seem to sync my controller or lighthouses at the same time.  It keeps syaing 'the headset must be plugged in before pairing any controllers'.  The headset constantly going to sleep never happened to me before, neither has not being able to install the software to use my Vive.

VR Cowboy since 1995
Vive Staff

Re: Disable headset sleep/standby

@DaVinster @MagNet @BuddyMocha @Weed @BrokenPoet

 

Interesting. And this all started recently? I'm wondering if rolling back the Nvidia drivers (assuming you all have Nvidia) would help. Is it mainly Elite Dangerous or is it other games as well??

Thanks,

-John C

"Welcome to the desert of the real."
Imaskari
New Arrival

Re: Disable headset sleep/standby

I only just got my Vive in the last couple of days, so I can't comment on what might have changed since it was like this from the begininning; but I can attest to having this same issue with other programs. I like to use MultiVR.se to watch youtube lying down, and going more than a handful of seconds without moving my head results in the headset going to sleep every time.

Labels