Can't install Intel WiGig


Can't install Intel WiGig

When trying to run ViveWirelessSetup.exe, the installer fails at installing Intel WiGig and says "Fail to install Intel WiGig. Please reboot PC and try again."


  • I've rebooted many times, also ran the installer out of C:\Program Files\VIVE Wireless\IntelWiGig\WiGigInstaller_VR_x64.msi. It gets to the end and then encounters an error and rolls back the install.
  • I've also deleted the IntelWiGig folder and re-ran ViveWirelessSetup.exe.
  • I've uninstalled SteamVR and reinstalled it. (Had to do this because DisplayLink wouldn't install initially)
  • Disabled anti-virus (Windows Defender)
  • Closed all running applications.


Event Viewer shows this:

Faulting application name: BPRGInst.exe, version: 4.0.10371.5, time stamp: 0x5b5d9ac6
Faulting module name: BPRGInst.exe, version: 4.0.10371.5, time stamp: 0x5b5d9ac6
Exception code: 0xc0000005
Fault offset: 0x000000000000edbf
Faulting process id: 0x53d4
Faulting application start time: 0x01d456e018bda421
Faulting application path: C:\Program Files\Intel\WiGig\Drivers\BPRGInst.exe
Faulting module path: C:\Program Files\Intel\WiGig\Drivers\BPRGInst.exe
Report Id: 6564eaa7-299f-47c7-9622-2aa150fafd1f
Faulting package full name:
Faulting package-relative application ID: 
Fault bucket 1796984940874063250, type 4
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: BPRGInst.exe
P2: 4.0.10371.5
P3: 5b5d9ac6
P4: BPRGInst.exe
P5: 4.0.10371.5
P6: 5b5d9ac6
P7: c0000005
P8: 000000000000edbf

Attached files:

These files may be available here:

Analysis symbol:
Rechecking for solution: 0
Report Id: 6564eaa7-299f-47c7-9622-2aa150fafd1f
Report Status: 268435456
Hashed bucket: f7fbaf660e02bbd5d8f02c486b865d92
Cab Guid: 0


Specs are: Windows 10 1803, Build 17134.285

core i7 6700k

32gb ram

GTX 1080


I'm not sure what else to try or do now...


Re: Can't install Intel WiGig

I tried doing a Windows Reset (told it to delete everything on the drive). Right afterwards, I installed Steam, SteamVR, and then tried ViveWirelessSetup.exe and still ran into the same issue.


Re: Can't install Intel WiGig

I ended up formatting the drive and reinstalling Windows. I was able to install it afterwards. A Windows Reset just wasn't enough.


Re: Can't install Intel WiGig

Were you using the 64bit version of windows 10?
Vive Staff

Re: Can't install Intel WiGig



It's interesting that reformating worked but a windows reinstall didn't. What version of Windows were you using? (64bit, 32bit?)


-John C

"Welcome to the desert of the real."

If your base station has a Fault 02/03 error or a red light or both, the ONLY solution is to contact our support on and set up an RMA. There is no user fix for this issue.

Vive Care Operating Hours: 9am to 6pm PST, M-F

Re: Can't install Intel WiGig

I am curious also. I run the HIVE at stanford university ( and we are investing a lot into the HTC VIVE pro with wireless. I have a fresh install of windoes 10 enterprise 64bit and the VIVE wireless driver install stopped at the "cannot install WiGig". I see the light on the card is blue. Not sure the issue. I will try to reinstall the OS tomorrow and see what happens. The system we are running is 2 i7-6950X with 512 Gb DDR4. 1TB SSD and an nvidia GP100.


Re: Can't install Intel WiGig

I was running 64-bit.


Re: Can't install Intel WiGig

I had these same issues with mine.  After a while, I ran this:

C:\Program Files\VIVE Wireless\IntelWiGig\WiGigInstaller_VR_x64 but I set it to compatability mode, then I ran the original installer again and it all works now


Re: Can't install Intel WiGig


Re: Can't install Intel WiGig

Wow that worked for me. Thanks! Now just need to get my headset to pair.


Re: Can't install Intel WiGig

I tried running the wigig_installer directly, that failed too.


at one point i think i stopped the installation mid way so it seems half the drivers are installed and it is refusing to over write the drivers. 

What did NOT WORK

uninstall steam vr and re installing


running the wigiginstaller_vr_x64.msi directley (with or without compatiblity) 


i deleted some wigig .inf file in the windows/system32 folder, and i tried to delete any registry (by clicking windows + r and typing "regedit") that contains the word "wigig"

i think deleting the inf file did it for me, because now i am able to reinstall the drivers and it is recognized correctly in the device manager, finally. now to continue installing the wireless !!


Re: Can't install Intel WiGig

I have also tried everything else different PCIe slots X1 X16 Gen2/Gen3 and Steam VR reinstall ... no reformatting but I did a fresh install to a second partition ... all no luck I will have to try your delete .ini and clean registry of any WiGig references next. Thanks for posting this @slvador


Re: Can't install Intel WiGig

I have the same problem. VIVE support is totally useless they even don't know abou this issue at all.


Me:12:05 PM
Cannot install Wigig 
Nathalie C. :12:06 PM
Hello, thank you for contacting Vive technical support. I’ll be more than glad to assist you today. 
Nathalie C. :12:06 PM
How may I help you? 

Me:12:06 PM
hi I have a problem with WiGig. I cannot install the driver. 
Nathalie C. :12:06 PM
Can you please be more specific? 

Me:12:07 PM
when I install the vivewireless setup file, it shows an errro with installing wigig. 
Me:12:07 PM
Fial to install intel WiGig 
Me:12:07 PM
Nathalie C. :12:08 PM
I understand. Have you tried with another PCIe slot? 
Me:12:08 PM
3 different slots 
Nathalie C. :12:09 PM
Still the same? 
Me:12:09 PM
Nathalie C. :12:11 PM
Okay, one last question. When and where did you buy the wireless adapter? 
Nathalie C. :12:11 PM
Okay, one last question. When and where did you buy the wireless adapter? 
Me:12:11 PM
a week ago? from Connection (prev. govconnection) 
Nathalie C. :12:13 PM
I understand. Basically, it is not recognizing the WiGig card since it seems to be defective. I advise you to contact the seller and ask for a return or replacement since the WiGig card is pretty much damaged. 
Me:12:13 PM
Me:12:13 PM
It comes with the original box never opened. 
Nathalie C. :12:14 PM
Still, the WiGig card is defective, otherwise, it should have worked with another slot. 
Me:12:15 PM
And it looks like a common problem when I searched about this. Someone just reinstalled Windows and it fixed the issue. Are you guys aware of this problem? 
Nathalie C. :12:16 PM
Personally, this is the first case I get. However, I'll make a follow-up on this to see if there are other customers who have contacted us with the same issue. 
Nathalie C. :12:17 PM
Also, if a Windows fresh install seems to work with this, you can follow this link site to know how to do so. 
Nathalie C. :12:18 PM
Thanks for that. Since it's something from the Community, I'll pass over this information here to make sure to find a solution for this in the future. 
I bought two kits and you are saying both cards are defective....interesting. 
Nathalie C. :12:21 PM
Well, it's either the wireless adapter or the PC. 
Nathalie C. :12:22 PM
You can try the Windows fresh install and if not, then please try with another PC Wireless Adapter compatible

Re: Can't install Intel WiGig

I just fixed the problem. What I tried:


reinstall steam and steamVR several tiems. 

tested the card with 4 different PICe slots. 

Deleted all "wigig" entries from my registry.  

tried to install the driver (in C:\Program Files\VIVE Wireless\IntelWiGig) in a comapatibility mode 


None of them worked.


I ran "Run compatitiblility trubleshooter"  -> "test the program". With this, I was able to install the driver. After this, I ran the ViveWirelessSetup and everything is working fine now. 






Re: Can't install Intel WiGig

Yup, all the same issues here! It turned out the drivers from Intel were not completely installed. Windows shut it down for some reason, midway and wouldn't allow for the updates.


In device manager I located the "Unknown" source and clicked to finish the install. Then updated all my Intel drivers and double checked all the Intel apps had been fully executed.


Then, after a restart, permanently deleted all files and downloads of Vive Wireless. Started a fresh download, ran it and all is good.


My takeaway, make sure all the Intel drivers are updated first and windows recognizes the card. Then download the Vive App.