Vive process start even when services are disabled

jumbli
Contributor

Vive process start even when services are disabled

I have the Viveport software installed. While testing on the Oculus, I set the Vive services to disabled and reboot. Occasionally the Vive processes still start up and take controll of the VR headset from the Oculus Home SDK and drop me in to the SteamVR / Vive loading screen. I have to use task manager to manually kill off the processes before I can continue developing.

 

I don't think users should have to disable the services or kill processes. The Vive processes should not auto load and take control unless the Vive is actively being used. For users that own both the Vive and Oculus, this may lead them to uninstall the Viveport software.

Working on the VR game Dimensional
Vive Staff

Re: Vive process start even when services are disabled


@jumbli wrote:

I have the Viveport software installed. While testing on the Oculus, I set the Vive services to disabled and reboot. Occasionally the Vive processes still start up and take controll of the VR headset from the Oculus Home SDK and drop me in to the SteamVR / Vive loading screen. I have to use task manager to manually kill off the processes before I can continue developing.

 

I don't think users should have to disable the services or kill processes. The Vive processes should not auto load and take control unless the Vive is actively being used. For users that own both the Vive and Oculus, this may lead them to uninstall the Viveport software.


Hi Jumbi!

 

Thank you for highlighting this to us. We are currently testing this and we will get back to you.

Cheezy
Visitor

Re: Vive process start even when services are disabled

This exact problem is still happening more than three years later. I disabled Viveport in services and it is still autostarting when I start windows 10. Can you please explain how to prevent this?