App crashes on launch

shrikky23
Explorer

App crashes on launch

Hey guys,

 

So I am trying to port my existing VIVE game to Vive Focus. As soon as the app launches, it shows a window in the home screen which is white/black and shortly closes it.  Here is my attached ADB log. Please let me know how I can solve this?

 

I use Unity 5.6.1p3 with 2X AA, Auto Graphics API turned off (Removed GLES2). Linear color space.

 

I have attached the ADB log 

PS : I have made 2 builds named MarsOdyssey and MarsOdyssey2 and the logcat shows both (To prevent any confusion)

 

Vive Staff

Re: App crashes on launch

Wave SDK Plugin supports from at least 5.6.3, and it's expected some errors on 5.6.1 due to previous experiences.

Thanks.

shrikky23
Explorer

Re: App crashes on launch

It was working with 5.6.1 sometime back(and the sample projects work as well). I did some reverts and re imported wave sdk and now it doesn't into my project. I am not able to figure out what the problem is, but it just won't work right. I don't mind upgrading to 5.6.3 but it will shed some light if we know that the problem is most likely due to Unity version and not something with the project.
shrikky23
Explorer

Re: App crashes on launch

I've updatd the project to 5.6.3. It still doesn't seem to work. I can't even see the Application Icon in the Vive Focus. It seems to build completely from the Unity side. However I am not abel to find the app icon on the focus.

Vive Staff

Re: App crashes on launch

Hi @shrikky23,

 

Are you using SDK 2.1.0?

Could you try if you put down and put back HMD to see if it's different?

It's a little weird, and please provide logcat again on your latest build.

Thanks.

shrikky23
Explorer

Re: App crashes on launch

Hello Tony,

 

yes I am using the latest SDK. I tried playing around with HMD, it doesn't seem to work. Infact build and run was atleast showing a 2D plane with black/white before I did the HMD firmware update. Now I don't see any icon and it doesn't launch the application when I do build and run (Using the BuildHelloVR script for my scene). I have to manually open the APK in the vive focus to install and play. Either way the game crashes and it doesn't run. I am attaching the logs with this message.

 

Please let me know if you need any other information.

Thanks,

Lak

Vive Staff

Re: App crashes on launch

Hi Lak,

 

We need full log to clarify since lack of key information.

From current log crash happened on 10:30, but beginning of system on 12:35.

--------- beginning of crash
08-21 10:30:58.031  3195  3257 F libc    : Fatal signal 11 (SIGSEGV), code 1, fault addr 0x4 in tid 3257 (UnityMain)
08-21 10:30:58.122  3260  3260 F DEBUG   : *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
08-21 10:30:58.123  3260  3260 F DEBUG   : Build fingerprint: 'htc/htc_miac/htc_miac:7.1.2/N2G47H/1044351.1:user/test-keys'
08-21 10:30:58.123  3260  3260 F DEBUG   : Revision: '0'
08-21 10:30:58.123  3260  3260 F DEBUG   : ABI: 'arm'
08-21 10:30:58.123  3260  3260 F DEBUG   : pid: 3195, tid: 3257, name: UnityMain  >>> com.htc.vr.samples.MarsOdyssey2 <<<
08-21 10:30:58.123  3260  3260 F DEBUG   : signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr 0x4
08-21 10:30:58.123  3260  3260 F DEBUG   :     r0 9a12d198  r1 00000000  r2 00000004  r3 9a12d1b4
08-21 10:30:58.123  3260  3260 F DEBUG   :     r4 9a12d1f8  r5 00000000  r6 9a12d198  r7 9a12cf90
08-21 10:30:58.123  3260  3260 F DEBUG   :     r8 e313c078  r9 c62af1b8  sl 9a4aaab9  fp 00000058
08-21 10:30:58.123  3260  3260 F DEBUG   :     ip 9a12d1c8  sp 9a12cf48  lr 9a12d1b4  pc 9a52f954  cpsr 00010030
08-21 10:30:58.134  3260  3260 F DEBUG   : 
08-21 10:30:58.134  3260  3260 F DEBUG   : backtrace:

 

 

--------- beginning of system

08-21 12:35:21.055  1362  1401 D StatusBarManagerService: hiding MENU key
08-21 12:35:21.065  1362  1401 D StatusBarManagerService: setSystemUiVisibility(0x160e)
08-21 12:35:21.065  1362  1401 D StatusBarManagerService: hiding MENU key
08-21 12:35:21.090  1362  1401 D StatusBarManagerService: setSystemUiVisibility(0x160e)
08-21 12:35:21.090  1362  1401 D StatusBarManagerService: hiding MENU key
08-21 12:35:21.101  1362  1401 D StatusBarManagerService: setSystemUiVisibility(0x160e)
08-21 12:35:21.101  1362  1401 D StatusBarManagerService: hiding MENU key

shrikky23
Explorer

Re: App crashes on launch

Hi I've attached the full logcat

Vive Staff

Re: App crashes on launch

Hi Lak,

 

I've sent you pm, please check it.

Thanks.