SRWorks not working with VIve PRO

SOLVED
Highlighted
DennisSSDev
Contributor

SRWorks not working with VIve PRO

Just downloaded the SRWorks SDK to run one of the example projects, but faced with a dark scene and  a white curved screen in front of me. I suppose this shouldn't be happenning as I've tried to scan the enviroment and no meshes have appeared. 

 

Here is the error that I see from the SRWorks logger:

[DEVICE_VIVE2_MODE2_0] [2018-04-30 17:02:36] [-!-ERROR-!-] [CODE: 0x9C42] M_MSCD_AcViStSrv_40002 @SteamCameraDevice::start:31

 

Any Suggestions??

Vive Staff

Re: SRWorks not working with VIve PRO

@DennisSSDev, Are you on the most recent Vive Pro Firmware and Nvidia drivers?

 

@Dario, have you seen this error? 

To reach Viveport's customer service team, email customerservice@viveport.com

To connect with a live support agent for hardware support, go to www.vive.com/support, click on "contact us" in the top righthand corner, and then opt to speak with a Live Chat agent

David R

Technical Specialist - San Francisco, CA; Monday-Friday

Click here to send me a PM

Moderator
Solution

Re: SRWorks not working with VIve PRO

Make sure you see the stereo camera in SteamVR aettings - camera - test. If you don't, try restarting
DennisSSDev
Contributor

Re: SRWorks not working with VIve PRO

Hi @Dario, that's exactly what was causing the issue. The camera was not enabled.

 

Excuse me for the lack of preconfiguration knowledge, just started out with the API Smiley Wink

 

Maybe it would be a good idea to explicitly mention the setting in the documentation?