SR Works Cameras not starting in Unity/Unreal

SOLVED
Jamie
Settler

SR Works Cameras not starting in Unity/Unreal

I can't get the SR works samples working right now. My Vive Pro is setup correctly as far as I can tell, with the test footage showing in SteamVR and in the Dashboard when I enable it. The camera passthrough is not happening in either the unity or unreal sample builds.

 

vivePro.PNG

I do get the following errors and warnings in the log for the Unity demo project however

[Vive SRWorks] [2018-07-02 09:21:20] [LOG] ViveSR_CreateModule() start
[JSON] [2018-07-02 09:21:20] [LOG] found steam install path
[JSON] [2018-07-02 09:21:20] [LOG] using device : LHR-80D5FFBA
[JSON] [2018-07-02 09:21:20] [LOG] using system : lighthouse
[JSON] [2018-07-02 09:21:20] [LOG] found device config file : C:\Program Files (x86)\Steam\config\lighthouse\LHR-80D5FFBA\config.json
[JSON] [2018-07-02 09:21:20] [-!-ERROR-!-] [CODE: 0x4E2A] parse faild @CheckCapability:213
[JSON] [2018-07-02 09:21:20] [-WARNING-] [CODE: 0x4E30] serial number not match(HMD-LHR-80D5FFBA & JSON-) @CheckCapability:219
[JSON] [2018-07-02 09:21:20] [-!-ERROR-!-] [CODE: 0x4E2A] parse faild @CheckCapability:224

Any help getting this working would be appreciated..  

DanY
Builder

Re: SR Works Cameras not starting in Unity/Unreal

Which SRWorks version are you using? Supposing v0.7.5.0 could fix your issue.

BTW, you could join the dedicated SRWorks forum in here, https://community.viveport.com/?_ga=2.243559745.598104857.1530588478-1489187922.1528193928, in there discussed similar phenomenon like yours.

Jamie
Settler

Re: SR Works Cameras not starting in Unity/Unreal

Yup. Looks like the Admin has moved my topic.
Yes I'm using the latest 0.7.5 examples.. I've read most of the posts here around similar issues.. the closest someone had was to unplug additional screens for example.. but given the camera are connect via USB I don't see how the video outputs would have an effect like this..

As for hardware setup I'm using a brand new Alienware 15 R4 with a 1080 qmax on board.. this means using a mini DP to mini DP cable for video.. as of right now everything is working beautifully except that the camera feed is not currently feeding into the app..

Like I said above the preview in the test is sweet and you can see the preview when you are in the steam VR room..

I've got those errors in the log however and this far is my only clue.. I'm going to try a desktop class system today to see if that corrects the issue.. but that being said it should be working on a laptop too..

I'm running the latest nvidia drivers and windows 10.. given that the laptop is new everything is a fresh install..

Look forward to discussing solutions here!

Jamie
Highlighted
Jamie
Settler

Re: SR Works Cameras not starting in Unity/Unreal

I've tried a desktop class machine with a 980 Ti and it works without a problem..   Windows 7 Pro..

tis a shame I can't get it working on the more capable laptop however..

 

 

KevinYYLai
Explorer
Solution

Re: SR Works Cameras not starting in Unity/Unreal

Hi Jamie,

 

it looks like your configure file "C:\Program Files (x86)\Steam\config\lighthouse\LHR-80D5FFBA\config.json" got some problem.

you can try these steps, see it works or not :

1. shut down steam & steamvr

2. go to "C:\Program Files (x86)\Steam\config\lighthouse" and delete the folder "LHR-80D5FFBA"

3. then try any SRWorks sample again(steam will re-download it)

 

if there still have any problem, please share the log file and LHR-80D5FFBA\config.json , thanks your help.

Jamie
Settler

Re: SR Works Cameras not starting in Unity/Unreal

Brilliant..  thanks @KevinYYLai  that now has it running 100% on the laptop..  such a simple fix bro!

 

cheers!

 

 

Mattrix
Visitor

Re: SR Works Cameras not starting in Unity/Unreal

Woot, Thank you!  After hours of troubleshooting, this did it for me. I did not have the folder you mentioned so I just deleted all of them. Steam downloaded them again when I fired Steam VR back up and everything worked. 

HYE3930
New Arrival

Re: SR Works Cameras not starting in Unity/Unreal

Hello. I'm try this problem.
When I restart SRWorks sample, folder is make one more time and It's crash too...
I want to solve this problem.
please help me...