No camera view in Demo

SOLVED
ITD-Weimar
Contributor

No camera view in Demo

Hi there,

I`m trying to test the ViveSR_Experience Demo scene, however I do not get any camera images so far.
 There is also a console error:

[ViveSR] Initial Framework : -1
UnityEngine.Debug:LogError(Object)
Vive.Plugin.SR.<StartFrameworkCoroutine>c__Iterator0:MoveNext() (at Assets/ViveSR/Scripts/ViveSR.cs:84)

 

The SRWork.log looks like this (there also some errors)

[JSON] [2018-11-07 13:11:36] [-!-ERROR-!-] [CODE: 0x4E2A] parse faild @CheckCapability:213
[JSON] [2018-11-07 13:11:36] [-WARNING-] [CODE: 0x4E30] serial number not match(HMD-LHR-A3D101AB & JSON-) @CheckCapability:218
[JSON] [2018-11-07 13:11:36] [-!-ERROR-!-] [CODE: 0x4E2A] parse faild @CheckCapability:222

[ENGINE_DEPTH_2_DLL] [2018-11-07 13:11:39] [-!-ERROR-!-] [CODE: 0x4E21] Invalid focal length: 0.000000 @ModuleDepth_Initialization:43
[ENGINE_DEPTH_2_DLL] [2018-11-07 13:11:39] [-!-ERROR-!-] [CODE: 0x4E21] Invalid baseline: 0.000000 @ModuleDepth_Initialization:45

[JSON] [2018-11-08 09:17:48] [-!-ERROR-!-] [CODE: 0x4E31] openvr api init fail @FindValidConfigFile:306
[JSON] [2018-11-08 09:17:48] [-!-ERROR-!-] [CODE: 0x4E31] openvr api init fail @FindValidConfigFile:306

 

Is there any fix?

 

@Jad @Dario

Moderator
Solution

Re: No camera view in Demo

Hi,  please take a look at this solution here and let us know if that helps:

 

http://community.viveport.com/t5/Vive-SRWorks-SDK/SR-Works-Cameras-not-starting-in-Unity-Unreal/m-p/...

 

 

ITD-Weimar
Contributor

Re: No camera view in Demo

that fixed it. thank you