Community Announcements
Got a new Deluxe Audio Strap? Here's how to attach it. Questions on Viveport Subscription? FAQS are here.

cannot launch viveport all of a sudden

Explorer

Re: cannot launch viveport all of a sudden

@Synthesis

I cannot reset the controller.

Holding the grip touchpad and menu buttons for any given amount of time does nothing for me when I plug in the controller via USB. Controller light turns orange to show charging, but that is all.

 

Unpairing and repairing the controllers did not resolve the issue.

 

Things I tried from Reddit (https://www.reddit.com/r/Vive/comments/4dnvzc/psa_things_to_try_if_youre_having_controller/)

1) Disabling HDMI Audio (Vive Audio) from the playback devices (Not sure why this is relevent but some people had success with this

2) I have an ASUS Board, but none of the ASUS Software is installed so there is nothing to uninstall

3) I have had this issue for almost a year, which means I have tried it with Windows 7, 8, 10 and their respective service packs.
4) Formatting this machine (I have done this several times, twice specifically in an attempt to fix various VIVE issues) does nothing. Same exact controller problems exist.

Vive Staff

Re: cannot launch viveport all of a sudden

Make sure you're plugged into USB 2.0 ports (not the blue 3.0 ports) 
ASUS has a compatibility issue in that regard.

"Welcome to the desert of the real."
Explorer

Re: cannot launch viveport all of a sudden

@Synthesis

1) Confirmed. USB 2.0 Ports

2) What do I do about it? What are my options?

3) I dont get the reference?

Vive Staff

Re: cannot launch viveport all of a sudden

1 & 2) That should fix it, as far as the USB problems go as long as you stay in USB 2.0 you're fine. At this point, make sure the controller is charged up, it may be a controller malfunction though, especially if you can't reset it normally. You may want to RMA the controller at this point though, if it's stuck in charging, won't pair and won't reset.

3) It's just my signature on the forum.

Thanks,

-John C

"Welcome to the desert of the real."
Explorer

Re: cannot launch viveport all of a sudden

[ Edited ]

@Synthesis

Its not stuck in charging.

When I plug it in via usb and turn it on, it works fine, paired and stuff. I can then disconnect it and use it freely
It will pair fine, while plugged in, just wont do it when its not plugged in, and it shuts off within seconds of turning it on.

It wont reset though, I have no idea why. I find it odd that BOTH controllers have the same issue, which is why i'm not convinced the controllers are the problem, but rather firmware or something else.

How do I go about an RMA If that is what needs to be done?

Vive Staff

Re: cannot launch viveport all of a sudden

"It will pair fine, while plugged in, just wont do it when its not plugged in, and it shuts off within seconds of turning it on."

How long has it been charging? Does it ever go to fully charged status?

Thanks,

-John C

"Welcome to the desert of the real."
Explorer

Re: cannot launch viveport all of a sudden

@Synthesis

Avg charge time is 2-3h ish per controller. Yes it does charge to full and the orange charge light turns white when complete.

Explorer

Re: cannot launch viveport all of a sudden

@Synthesis

 

I haven't heard back in a week from anyone.
Is there any other troubleshooting steps i can take?

Vive Staff

Re: cannot launch viveport all of a sudden

@rboelens

 

Hi, sorry about the wait but I do have a couple of new things we can try.

Uninstall third party USB Host Controller drivers

Due to compatibility, some PC hardware manufacturers may implement different USB Host Controller drivers. These third party drivers may interfere with the Vive hardware, causing it not to function properly. Replacing third party drivers with generic windows drivers is expected to resolve this issue.
1. On the computer, press [Windows] key + R.

2. On the Run dialog, type “msc” unquoted.

3. Extend the Universal Serial Bus controllers

4. Look for a driver that includes the words “eXtensible Host Controller” or “xHCI

5. Right click on it and select Uninstall driver.

6. Restart the computer and Windows will install a generic version of it.

Also, I don't know if you tried it, but you can also remove all the USB Drivers and start over with that. 

Remove All SteamVR USB Devices

The Vive system is composed of about 9 different USB drivers, including Bluetooth, controllers, camera, receivers and audio, among others. Due to different reasons, like software updates, change of connections, system updates or malfunction of a device, the USB drivers might get into conflict and reinstalling them is a good way to get everything back to its working state.

  1. Go to SteamVR > Settings > Developer.
  2. Click on Remove All SteamVR USB Devices.
  3. Once finished, the program will prompt a confirmation of the process.
  4. Disconnect the Link box AC Adapter and the Link box USB cable from the computer.
  5. Close SteamVR.
  6. Connect the AC Adapter back to the Link box and then connect the USB cable directly to the computer to a USB 2.0 port.
  7. Open SteamVR and check if all the devices all properly recognized, by going to SteamVR > Settings > USB > Refresh.
    1. These are the default drivers:

 

Vive Link Box:

·         Hub

·         Hub Controller

·         Bluetooth

 

Vive Headset:

·         Watchman Board

·         Camera

·         Audio Device

·         Main Board

·         Wireless Receiver 1

·         Wireless Receiver 2

 

Note: This list includes the drivers of the devices directly connected to the computer by USB, as it is the HMD and Link box. Controllers and Base Stations are connected to the headset through Bluetooth and then to the computer, so these devices are not going to be visible on this list.




Thanks,

-John C

"Welcome to the desert of the real."
Explorer

Re: cannot launch viveport all of a sudden

@Synthesis

We already tried to remove SteamVR Drivers, no effect.

Also my Extensible Controllers are already the MS Ones (See "Microsoft") at the end of all 3

Vive3.png

Architect

Re: cannot launch viveport all of a sudden

Any chance you have a racing wheel with pedals or a flight stick with throttle control plugged in, if so, try unplugging it. Some people have Vive controller problems with the throttle part of some racing and flying controllers. Just a stab in the dark.
Regards: Jack
Vive Staff

Re: cannot launch viveport all of a sudden

@CaTaPulT @rboelens

 

You can also try this: https://support.steampowered.com/kb_article.php?s=3c5db199e026e5fefe1d54a6360b03f8&ref=2748-WEIK-956...

That will definitely resolve any USB issues assuming that's the root cause of the issue.

Thanks,

-John C

"Welcome to the desert of the real."
Contributor

Re: cannot launch viveport all of a sudden

[ Edited ]

I finally found the solution:
Solution: Disable Antivirus
--(My Anti virus is kaspersky-I didn't really disable it,I just disable System Watcher and application control but other components like antivirus firewall .etc. are running like charm) it seams it's something like maleware.
before this solution ,I couldn't run some games apps via viveport but Steam games didn't have any problems.reinstallation didn't work or any other ways.
So solution for me is disabling all Antivirus (windows 10 defenders and kaspersky and node or anything els or just disable the part like mine. Smiley Happy

Vive Staff

Re: cannot launch viveport all of a sudden

@tbehrang Try what @tbehrang did and disable any and all antivirus software.

Thank you,

-John C

"Welcome to the desert of the real."