Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

SOLVED
Yendor33
Settler

Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

Hello Technical Support,

 

I pre-ordered the Vive Pro via Amazon and it arrived on April 5, 2018.  There were problems during setup, but I eventually got most of the Vive Pro to work.  When I first sent audio to "VIVE Pro Multimedia Audio" [via SteamVR Settings Audio on the Desktop] the hand controllers could not be seen in the HMD.  Today I joined the SteamVR Beta, started Steam as Administrator and now that is nNo Devices RecognizedNo Devices Recognizedot a problem.

 

When I ask the desktop display of SteamVR/Settings/USB to "Refresh" all of the Vive Devices are greyed out except the "Bluetooth".

 

The "SteamVR System Report" does show all of the Vive Devices and the PC Device Manager shows all of the Devices as well.

 

The Vive Pro HMD works with the exception of the Camera(s).  I have tried multiple USB Ports including USB 3.1 Gen 1 and Gen 2.  I have followed all of the Troubleshooting Steps including deletion of all Vive Drivers.

 

Inside the HMD the Camera will show an occasional static No Visual from CameraNo Visual from Cameraframe of my play area but then go black.  On the Desktop "SteamVR/Settings/Camera/Test Camera Rate" the image is black and there are 3 red X's for Camera Streaming, Camera Tracking, and Camera Rate Valid.  I am unable to change the Camera Rate from 60 Hz.  If I set it to lower than 60 Hz, SteamVR restarts and it is back to 60 Hz.

 

As I've mentioned, the Vive Pro works as a display and with audio and I've played many a game with it.  I am concerned that:

1) SteamVR USB cannot display the majority of the Vive Devices, and

2) The Camera does not work at all.

 

I am posting this as an open question to Tech Support.  I am curious if anyone else is having these issues or if their Vive Pro are working flawlessly.

 

 

 

Vive Staff

Re: Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

@Yendor33

 

Hi. Can you tell me a little more about your set up? Computer model, or components if custom? Operating System version? Are you using an adapter for any part of the set up or as it is out of the box?

Thank you,

-John C

"Welcome to the desert of the real."
Yendor33
Settler
Solution

Re: Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

@Synthesis

 

I have tried describing my system multiple times yesterday in many replies.  This Forum System marked each one as SPAM and deleted them.

 

i7-5960X, 32 GB, MSI X99A Gaming Pro Carbon, 2xAsus Strix OG 1080Ti's, 4K TV as Monitor 1, LG 29" Monitor 2 using HDMI to DP Adapter.

 

Vive Pro connects directly to my Windows 10 Pro [Build 16299] PC [Display Port and USB].  I do not use any adapters.

 

On 4/11/2018 following a Windows "Patch Tuesday" Update plus a Steam Client Update the Camera(s) started working.

 

My last mild concern is that the SteamVR desktop display for Settings/USB only shows the Bluetooth Device (as seen in the first picture above).  All of the other Vive Pro subcomponents are greyed out.  However this is simply an issue, not a problem.  The Vive Pro is fully functional despite the SteamVR Desktop Window Display.

 

Thank you for your time [and I hope this Reply finally sticks].

nishanh
Contributor

Re: Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

I have this exact same problem, down to every symptom as described by the OP. Unfortunately, I can't resolve it. I've tried several USB ports, upgraded headset firmware, reboots - still nothing from the cameras.

 

I do get the audio "pass through" when entering "room view" in Steam, FWIW.

 

Windows 10 Pro 64bit, GTX1080, 32MB RAM, Intel i7 3930K 3.2Ghz

Yendor33
Settler

Re: Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

@nishanh

I also got the "audio pass through" that you described when using "Room View".  The audio pass through [from the Vive Pro Microphones] continues even when the cameras are working.

 

There were some extra steps that I took to get the cameras to work [I did attempt to write them but they were marked as SPAM and deleted by this Forum System]:

 

1) Close ALL other programs [I closed MalwareBytes, Skype, Outlook, and WinPatrol]

2) Run SteamVR in Beta [described elsewhere]

3) Close Steam and then run it as Administrator [described elsewhere]

 

Then the Cameras started to work without even needing to reboot.

 

 Once the Cameras started working, they continued to work without the need for the extra steps.  That is, they work with Steam in normal mode and while the other programs are running.  I don't need to take any extra steps to get them to continue working after they initially started functioning.

 

I hope the extra steps above work for you as well.

nishanh
Contributor

Re: Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

@Yendor33

I got it working. Apparently, I didn't try enough USB ports (I have over a dozen, not counting the hubs). I finally found one it was happy with.  I do wish to thank you for taking the time out to offer additional suggestions though.

Labels