Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

SOLVED
Yendor33
Settler

Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

Hello Technical Support,

 

I pre-ordered the Vive Pro via Amazon and it arrived on April 5, 2018.  There were problems during setup, but I eventually got most of the Vive Pro to work.  When I first sent audio to "VIVE Pro Multimedia Audio" [via SteamVR Settings Audio on the Desktop] the hand controllers could not be seen in the HMD.  Today I joined the SteamVR Beta, started Steam as Administrator and now that is nSteamVR USB Devices Mostly Blank.JPGNo Devices Recognizedot a problem.

 

When I ask the desktop display of SteamVR/Settings/USB to "Refresh" all of the Vive Devices are greyed out except the "Bluetooth".

 

The "SteamVR System Report" does show all of the Vive Devices and the PC Device Manager shows all of the Devices as well.

 

The Vive Pro HMD works with the exception of the Camera(s).  I have tried multiple USB Ports including USB 3.1 Gen 1 and Gen 2.  I have followed all of the Troubleshooting Steps including deletion of all Vive Drivers.

 

Inside the HMD the Camera will show an occasional static SteamVR Camera Frame Rate Test.JPGNo Visual from Cameraframe of my play area but then go black.  On the Desktop "SteamVR/Settings/Camera/Test Camera Rate" the image is black and there are 3 red X's for Camera Streaming, Camera Tracking, and Camera Rate Valid.  I am unable to change the Camera Rate from 60 Hz.  If I set it to lower than 60 Hz, SteamVR restarts and it is back to 60 Hz.

 

As I've mentioned, the Vive Pro works as a display and with audio and I've played many a game with it.  I am concerned that:

1) SteamVR USB cannot display the majority of the Vive Devices, and

2) The Camera does not work at all.

 

I am posting this as an open question to Tech Support.  I am curious if anyone else is having these issues or if their Vive Pro are working flawlessly.

 

 

 

Vive Staff

Re: Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

@Yendor33

 

Hi. Can you tell me a little more about your set up? Computer model, or components if custom? Operating System version? Are you using an adapter for any part of the set up or as it is out of the box?

Thank you,

-John C

"Welcome to the desert of the real."

If your base station has a Fault 02/03 error or a red light or both, the ONLY solution is to contact our support on vive.com and set up an RMA. There is no user fix for this issue.

Vive Care Operating Hours: 9am to 6pm PST, M-F
Yendor33
Settler
Solution

Re: Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

@Synthesis

 

I have tried describing my system multiple times yesterday in many replies.  This Forum System marked each one as SPAM and deleted them.

 

i7-5960X, 32 GB, MSI X99A Gaming Pro Carbon, 2xAsus Strix OG 1080Ti's, 4K TV as Monitor 1, LG 29" Monitor 2 using HDMI to DP Adapter.

 

Vive Pro connects directly to my Windows 10 Pro [Build 16299] PC [Display Port and USB].  I do not use any adapters.

 

On 4/11/2018 following a Windows "Patch Tuesday" Update plus a Steam Client Update the Camera(s) started working.

 

My last mild concern is that the SteamVR desktop display for Settings/USB only shows the Bluetooth Device (as seen in the first picture above).  All of the other Vive Pro subcomponents are greyed out.  However this is simply an issue, not a problem.  The Vive Pro is fully functional despite the SteamVR Desktop Window Display.

 

Thank you for your time [and I hope this Reply finally sticks].

Highlighted
nishanh
Contributor

Re: Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

I have this exact same problem, down to every symptom as described by the OP. Unfortunately, I can't resolve it. I've tried several USB ports, upgraded headset firmware, reboots - still nothing from the cameras.

 

I do get the audio "pass through" when entering "room view" in Steam, FWIW.

 

Windows 10 Pro 64bit, GTX1080, 32MB RAM, Intel i7 3930K 3.2Ghz

Yendor33
Settler

Re: Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

@nishanh

I also got the "audio pass through" that you described when using "Room View".  The audio pass through [from the Vive Pro Microphones] continues even when the cameras are working.

 

There were some extra steps that I took to get the cameras to work [I did attempt to write them but they were marked as SPAM and deleted by this Forum System]:

 

1) Close ALL other programs [I closed MalwareBytes, Skype, Outlook, and WinPatrol]

2) Run SteamVR in Beta [described elsewhere]

3) Close Steam and then run it as Administrator [described elsewhere]

 

Then the Cameras started to work without even needing to reboot.

 

 Once the Cameras started working, they continued to work without the need for the extra steps.  That is, they work with Steam in normal mode and while the other programs are running.  I don't need to take any extra steps to get them to continue working after they initially started functioning.

 

I hope the extra steps above work for you as well.

nishanh
Contributor

Re: Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

@Yendor33

I got it working. Apparently, I didn't try enough USB ports (I have over a dozen, not counting the hubs). I finally found one it was happy with.  I do wish to thank you for taking the time out to offer additional suggestions though.

Uri
Explorer

Re: Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

Hi there,

I tried every described step without success. I'm still having the same issue described on this post.

Does anyone solved this doing something different?
Thanks in advance.

Vive Staff

Re: Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

@Uri 

Dear Uri,

So basically your VIVE Pro is working but UI (everything) is grey out in USB settings except Bluetooth. Am i correct? 

Thanks. 

Uri
Explorer

Re: Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

Hi @odmlover
Yes, you're right. The thing is that I recently changed my computer, and in the old one (running Windows 7 64bit) the cameras were working fine, so there is no hardware problem, but in the new PC (Windows 10 Pro 64bit 1803) I'm having exactly the issue described. 
Thanks.
Best.

Vive Staff

Re: Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

@Uri

Dear Uri, 

In your case, if your camera is working on Win7, then this indicates yuour hardware(camera) is fine. 

 

We have been hearing several users are having USB driver problem with Win10 1803 version. 

 

Would it be possible if you can roll back to previous version of Win 10 and give it a test?

 

Thanks. 

 

Uri
Explorer

Re: Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

Dear @odmlover

Unfortunately I cannot rollback, as it is a new clean installation, I just installed the last Win 10 Pro version.
I'm also searching on other forums and you're correct, there are more users in the same case. 

Looks like by default Win 10 is blocking the access to the camera, and this is the proposed solution (I'll try it later, when I go back home) and let you know.

1. Turn on Camera to Fix Camera Not Working in Windows 10

If your camera is not working after the Windows 10 update, you need to check whether your camera is turned on first. Follow the below instructions to enable the camera.

Step 1. Click on Start, and tap Settings from the Start screen

Step 2. Select Privacy from the Settings window

Step 3. Select Camera from the left pane

Step 4. Turn on the Let apps use my camera setting

Step 5. In the Choose apps that can use your camera list, turn on the camera for all applications that need access to your camera

Uri
Explorer

Re: Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

Dear @odmlover

Unfortunately I cannot rollback, as it is a new clean installation, I just installed the last Win 10 Pro version.
I'm also searching on other forums and you're correct, there are more users in the same case. 

Looks like by default Win 10 is blocking the access to the camera, and this is the proposed solution (I'll try it later, when I go back home) and let you know.

1. Turn on Camera to Fix Camera Not Working in Windows 10

If your camera is not working after the Windows 10 update, you need to check whether your camera is turned on first. Follow the below instructions to enable the camera.

Step 1. Click on Start, and tap Settings from the Start screen

Step 2. Select Privacy from the Settings window

Step 3. Select Camera from the left pane

Step 4. Turn on the Let apps use my camera setting

Step 5. In the Choose apps that can use your camera list, turn on the camera for all applications that need access to your camera

Uri
Explorer

Re: Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

Dear @odmlover

Unfortunately I cannot rollback, as it is a new clean installation, I just installed the last Win 10 Pro version.
I'm also searching on other forums and you're correct, there are more users in the same case. 

Looks like by default Win 10 is blocking the access to the camera, and this is the proposed solution: Turn on the Let apps use my camera setting on Windows privacy settings (I'll try it later, when I go back home) and let you know.

Thanks.

Uri
Explorer

Re: Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

Hi guys,

Finally I solved it.  Smiley Wink

Here are the steps done:

1.- Plug the linkbox to a USB 2.0 port.

By doing this, the camera was recognized automatically on Steam VR Beta (camera settings)

2.- Move back to SteamVR (no Beta) version. (Optional)

3.- Plug the linkbox into USB 3.1 port (from the tower front planel, directly coming from the MB, not from its back panel).

That's all. 

After this I can enjoy the camera hardware again. Note: On the USB SteamVR settings, it stills only recognizes the Bluetooth, but again, the camera is working fine on Windows 10 Pro 1803.

Hope this will be helpful to someone else with the same issue.

Cheers.

 

Juang3d
Contributor

Re: Vive Pro Not Recognized by SteamVR, Cameras Do Not Work

I have the same problem, same system, 5960X with an Asus X99-A

I went through a hell to make my Vive Pro working, but it´s finally working (also the hardware was not the problem because I tested it in a different PC)

But the cameras are not working at all, no matter in what USB I connect it, 3 or 2, no matter, cameras are not working, I enabled everything in privacy for the cameras, and tried the things said here, I even reinstalled Steam completely, nothing seems to be working.

I also have Windows 10 Pro 64Bit 1803

Please, help.