Community Announcements
Got a new Deluxe Audio Strap? Here's how to attach it. Questions on Viveport Subscription? FAQS are here.

So temperamental

Pioneer

Re: So temperamental

[ Edited ]

Directly from your site the massive download button...

 

I am getting to the point now where I want to bring a hammer to the bloody lot of it!!!!

Here is my step by step encounters I have had this morning.

 

Loaded Steam and clicked the VR icon.  The base stations booted up and showed green.  I turned the 100% charged gamepads and they also showed green as did the headset.  Started a game (from steam).  Game began to load, I put on the headset and it was a black screen.  Looked at steamVR and both base stations were now grey.  The physical base stations were up as I could see the LED array.  I shut down SteamVR and this also put the base stations to sleep ... you know the same basestations that 1ms previous the software couldnt even detect.  I then though ffs and uninstalled steamVR and unblugged the link adapter and rebooted the PC.  On reboot I begain the reinstallation of steamvr.  Once installed I plugged in the the link box and the VR logo appeared in Steam which I then clicked.

The basestations came out of sleep, everything showed green, I started the game and put my headset on.  I could see the default Vive Real logo fine and the game loading screen.  I could see my two controllers OK showed 4 power bars.  Then the steam menu came up and my controllers had vanished.  I looked at the PC and both of the controllers were flashing green, about 5 seconds later the twop Base stations icons went grey as they went to sleep.

 

And its this palava every 12 hours that is making me just scream.

 

At this moment in type I can see both controllers when I have the headset on, but in steamvr one of them is grey

Constructor

Re: So temperamental

@Emexrulsier Is the Vive hardware the only Bluetooth you have installed on the PC?

New Arrival

Re: So temperamental

I had a quick question. I noticed in this message you say plug into 2.0 instead of 3.0. But if i recall the manual says use 3.0. I bring this up, so far i dont have the issue where the base stations dont come up, it happens once in a blue moon, but i do get where my controlls will not connect, i have to go through a dance of plugging them into pc with usb and syncing the controls. Eventually it works, but sometimes i will be at it for a couple hours. sometimes right away. Would using 2.0 fix this, or should i keep with the 3.0???

Highlighted
Architect

Re: So temperamental

[ Edited ]

From reading these forums for the last couple months, it seems plugging in the Vive into a USB 2.0 port instead of a 3.0 port fixes many issues.

As for some of the things you have described, I think the latest version of SteamVR is buggy as hell (the one that introduces SteamVR Home), I also have connection problems with the headset, controllers and lighthouses, I have to often do multiple reboots to get it all working but once it's working, it seems to work well. For now, I would turn off the option of put your lighthouses to sleep when not being used, this seems to have helped for me since when I had that turned on, often the lighthouses wouldn't wake up or be detected. I hope Steam fixes SteamVR soon, it was a lot more stable a few versions ago. It's one of the things I hate about Steam, they shove their updates down your throat instead of asking if you want to update..... the way I look at it, if it ain't broke, don't fix it. And to be honest, I have absolutely no use for SteamVR Home, I have it turned off, just a waste of hard drive space.

Regards: Jack

Pioneer

Re: So temperamental


MartinMarty wrote:

@Emexrulsier Is the Vive hardware the only Bluetooth you have installed on the PC?



Yeah the link box is the only Bluetooth I have. The issue seems to be a mix of bluetooth and the viveport software. Surely I shouldnt be seeing popups like this when viveport launches...

viveport.PNG

 

I am going to remove vive software again (done it a few times).  What would you recommend to make sure every trace of it is removed after a uninstall.  Also I am going to remove the BT driver (as the vive version vs the steam version appear to differ) and then do a driver a cleaner to 100% remove it before reinstalling.

Architect

Re: So temperamental

Take a look at "Revo Uninstaller" this is a great utility to revome everything when uninstalling a program! I love this utility.

Regards: Jack

Pioneer

Re: So temperamental

ok so far so good "touch wood" (well 90%).  I am seeing the basestations green most of the time within steam vr.  That developer console isn't popping up anymore.  The only issues I am getting is that the steamvr software isn't always walking the BSs up and I have to press the button on the back of each unit.

 

I have also noticed a random crash when I press the menu button, the vr headset screen goes light blue and a blue line shines out from where my controller was at the vr softeare crashes.  Had this happen 3 or 4 times now.

Pioneer

Re: So temperamental

ok last update, I am not going to bother anymore I think I just have to limp along for a while until all the software has matured a bit more.

 

I think what I would suggest is fully testing and investigating the power management of the basestations over bluetooth.  In the last 12 hours I have loaded steamvr, both of them were green then seconds later they were grey.  When I looked at them they had gone to sleep, I had to press the buttons on the back of each unit to wake them up.  I then have experienced shutting down the machine and come back a few hrs later to notice both basestations are still fully powered up (base on the led array fullly light and bright green light).

I have double checked steam vr and it is checked to put them to sleep when closing steam, but obviously this is flakey at best.  Not sure on the text but are the Basestations able to detect controllers, headsets when steamvr and/or the pc is turned off?  Maybe the firmware could be updated to force sleep mode if no movement or detection of the linkbox after a certain timelimit has surpased.

 

If it was me, I wouldn't have chosen the BT option to connect peripharals and gone for much more stable 2.4Ghz Wireless connection for devices.  Better range and stable connection.  Maybe version 2 of the pads, linkbox, and bs Smiley Very Happy

Pioneer

Re: So temperamental

[ Edited ]

I like the vive but at the same time I f*cking hate the piece of sh*t!!!!

Every review, every video, every blog etc talks about how good it is but at the same time mentione how you have to fanny around for 30 mins to get it working every bloody day and they are so **bleep** right!!!!!!!!

45 b*stard minutes and I am still not working.  SteamVR one second detects steam 30 seconds later it doesn't.  Click the link to "start steam" and it just bring the steam window into focus.  I expect steam vr to put the basestations to sleep when I shut it down, not when im bloody in the middle of an application!


Architect

Re: So temperamental

I was having nothing but problems when I used the bluetooth feature for turning the lighthouses off when not in use, so I turned off the Bluetooth feature and now everything works well. Now, when I'm done for the day, I just turn off the 2 cheap powerbars I have the lighthouses plugged into, one also powers the Vive and I also unplug the Vive's USB cable. So no part of the Vive is getting power while I'm away.

Since the last update of SteamVR, my setup has been working flawlessly, I turn it all on, fire up Steam, hit the VR tab and everything gets detected.

I should also mention I do NOT have the VivePort software installed nor do I have the Oculus Home hiden files loaded. Both those seem to cause grief from time to time.

Regards: Jack

Pioneer

Re: So temperamental

I have viveport installed because I have purchased games and subscriptions.  I might just put the basestations on a timer so I dont forget to power them down otherwise they stay on for ever and a day.  Weird that they support stanby, they support communications so why can't they have inbuilt standby when for example bluetooth is not connected (before the link box is powered down when pc is off)