Second controller I pair has awful tracking

oddball
Explorer

Second controller I pair has awful tracking

Hello!

I really need some help, I'm completely lost on what's causing this.

The specific issue is that the SECOND controller I pair has absolutely horrendous tracking. The issue is not controller specific. I have tried unpairing them and pairing them in reverse order and the issue remains the same. It seems that the issue is not specific to either controller in this case.

I don't know how the controller tracking is handled so I'm not sure how to proceed with troubleshooting. I have spent hours with HTC support and have reset/reinstalled everything. Nothing solves this.

No matter what, the first controller paired has flawless tracking and the second simply teleports/loses tracking constantly. I haven't tried a totally new environment/PC yet, but will as soon as I can. In any case though, why does one work perfectly and the second hardly works at all?

 

Any insight would be greatly appreciated, I'd just like to start having some fun.

Vive Staff

Re: Second controller I pair has awful tracking

     Can you share some details about your current setup so we can start to dive deeper into the issue?  Motherboard, USB configuration, as well as OS are the most helpful things to share. Based on your post I have a suspicion that it could be related to your USB configuration. I've seen similar issues resolved with a PCI-E USB card. Support has likely already recommended this but ensure that you've tried disabling the camera via SteamVR and are not on a USB 3.1 port (and try a USB 2.0 if you have one). 


- David R

Technical Specialist; San Francisco, CA

oddball
Explorer

Re: Second controller I pair has awful tracking

Hey there!

 

Thanks for your response, I really appreciate it.

 

This is the laptop I'm trying to use: https://www.asus.com/uk/Laptops/ROG-GL702VM/

It has reviews that discuss how it performs with the Vive, so I'm betting/hoping that there's no incompatability there. 

 

I have three USB 3.0 ports and I've tried all of them to no avail. The only device I have plugged in via USB is my Vive. I also have the camera disabled. The laptop is running Windows 10.

 

I should have a friend coming over with their PC later today, so hopefully I can then determine if it's an environment or secret laptop issue that's causing this. 

Vive Staff

Re: Second controller I pair has awful tracking

Try uninstalling Asus AI suite; it's known to cause some fatal compatiblity issues. You can use USB View to get a better picture of how the Vive is interacting with your laptop hardware. Keep us updated on the results of your test so we can better determine if it's an issue with the Vive hardware or the laptop. 


- David R

Technical Specialist; San Francisco, CA

Vive Staff

Re: Second controller I pair has awful tracking

Does the same controller exhibit the behavior regardless of which hand you are holding it in or have you noticed/tested if both controllers exhibit these symptoms on one side vs the other?

 

 

CaTaPulT
Architect

Re: Second controller I pair has awful tracking

Maybe mark the problem controller with a piece of tape so you know which controller is which and see if it's always the same controller giving you problems. If it is the same controller, then it may need to be serviced (possibly one of the small ribbon cables within is not making proper contact). I hope you get everything working fine soon.

Regards: Jack

oddball
Explorer

Re: Second controller I pair has awful tracking

It unfortunately doesn't matter which hand I hold it in, the second controller I pair simply goes bonkers. Good thought though!

oddball
Explorer

Re: Second controller I pair has awful tracking

On marking them and narrowing down a problematic controller: after quite a bit of testing it seems that the issue isn't unique to either controller. I marked them by adjusting the wrist straps differently and tested pairing them in a different order and tried playing with them individually. Both controllers work perfectly on their own and go crazy if they're the second controller I pair.

 

Will look into Asus AI and using USB View in a few hours - thank you for your insight folks!

 

Hopefully we can figure out just what's causing this, such a frustrating and odd issue.

Vive Staff

Re: Second controller I pair has awful tracking

@oddball We'll definitely keep working with you on getting this sorted.  I'm curious (and this may not lead to a solution) but if you go to SteamVR menu, then Settings and select Audio.  In the Default Playback dropdown set it to HTC VIVE HDMI Audio and let me know if that changes the controller tracking behavior you are experiencing.

oddball
Explorer

Re: Second controller I pair has awful tracking

@jagibson Just tested out the HDMI audio change, same controller behavior unfortunately.

 

@VibrantNebula I couldn't find any trace of Asus AI or similar software on my laptop, so we're all good on that front. I took a look with USB View but I'm not really sure what I'm looking for honestly. Have attached a screenshot of the overview if that's helpful.

usbview.JPG

 

 

 

 

 

Friend will be coming over tomorrow with a computer to test with, will hopefully have some new leads then. Thanks again for your assistance!

Vive Staff

Re: Second controller I pair has awful tracking

     The Asus AI just puts all of the problematic services into one theoretically convenient place which allows you to disable them in one step. The services are likely still there but in the background. The last bit of advice I can give at this point is open up the task manager as an admin, find the services tab on the far right, hit sort by name, and see what Asus services are running. Try disabling/stopping them and seeing if that helps. Be sure to have steamVR closed when disabling the services and note the state of everything before you start making changes. 


- David R

Technical Specialist; San Francisco, CA

Vive Staff

Re: Second controller I pair has awful tracking

@oddball 

 

Let me know if you've tried these steps before but this will flush the system of any previous/existing pairings.  After you perform these steps go through the pairing for each one and let me know if you notice any difference:

 

  • On the PC, browse to C:\Program Files(x86)\Steam\steamapps\common\SteamVR\tools\lighthouse\bin\win32
  • Run lighthouse_console.exe
  • Type unpairall in the console window and then hit enter.
  • Once finished, the console window will display two identifiers as confirmation.
  • Close the console and restart SteamVR.
  • Attempt to pair the controllers again.

 

 

oddball
Explorer

Re: Second controller I pair has awful tracking

@VibrantNebula: Double checked for any problematic Asus services, only found one for my laptop's trackpad. No dice there unfortunately.

@jagibson: I have indeed unapired through console before, that has become one of my bread and butter troubleshooting steps while trying to figure out this weird issue.

 

Thanks for your suggestions!

 

On another note, I was able to test another PC at my home here today. We expereinced the same issue unfortunately, the second controller that we pair goes absolutely bonkers. Was again able to determine that the issue is not unique to either lighthouse or controller after testing.

 

I have some tripods coming in tomorrow that will let me test at a friend's house, I might be able to fit that into my day tomorrow. If the issue persists over there, I guess I just RMA all of my equipment? I can't isolate it to any one piece so I don't know what else I could do. The physical store I bought it from has said that they will not offer any sort of exchange. (Thanks GameStop)

 

I appreciate your help so far, thanks again for that. Will keep you updated after I test a new envrionment out.

Vive Staff

Re: Second controller I pair has awful tracking

@oddball

 

Is that second PC, by any chance, also using an ASUS motherboard? I'm curious.

Thanks,

-John C

"Welcome to the desert of the real."
Highlighted
CaTaPulT
Architect

Re: Second controller I pair has awful tracking

For what it's worth, I'm using a desktop with a Asus motherboard (Sabertooth Mark II motherboard) and am NOT having problems. I do have a couple Asus program  but not Asus Ai suite.

My Vive is connected to a USB 2.0 port.

I'm running a i7 4790k CPU (4.0 ghz) stock (not overclocked)

24 gigs of Kingston Hyper-X ram

a MSI GTX 980 video card stock (not overclocked)

Windows 10 Pro on a SSD

Steam folder is on my D: drive which is a 1tb HDD

The only time I seem to have problems is when SteamVR does a update to a newer version which introduce new problems, but they normally get that fixed within a day or two with a newer update.

I do not have VivePort installed and I do not have Oculus Home's hidden files running in the background (processes). I did notice that SteamVR seems to run better without those two programs (processes) running in the background.

Regards: Jack