Community Announcements

Need help with Viveport? Read this FAQ for information.

How to move Viveport applications to another drive

New Arrival

How to move Viveport applications to another drive

After copying files I tried changing registry paths and grepping D:\HTC\Vive\ApplicationList with the new path but nothing works.

Please advise.

 

2 REPLIES
Vive Staff

Re: How to move Viveport applications to another drive

Can you tell me more about the behavior you're seeing after moving the Viveport applications to the new file path? Is it that Viveport does not see the applications in the Library, or...?

If the issue is that they are missing from the Library, I would recommend changing the default app folder to see if that helps. You can do this in the Settings tab, and newly downloaded apps will be downloaded to the file path specified. If changing the Default App Folder setting/path to the file path you moved the already installed apps does not result in the apps being displayed in the Library, I would recommend uninstalling the apps and reinstalling them (with the new file path specified for the Default App Folder).

Hope this helps!

Contributor

Re: How to move Viveport applications to another drive

There is another thread with this same problem here. This old thread was written in 2016. I'm writing in this thread as this topic seems more recent being written in 2017 - two months ago. I'm writing this as of 5_19_17 and it still seems to have this same bug.

 

When I go to setting in the Viveport app. There is the default location of:

c:\ProgramData\HTC\Vive

 

When I try to change it to:

D:\HTC\Vive\ViveApps

nothing happens.

 

I mean the file path will be chang in the UX but it does not actually follow the change. When I install an app it still goes to the default location of c:\ProgramData\HTC\Vive, even if I am to restart the application.

 

When I restart the Viveport app and go back to the Settings tab, the file path will be changed to the default location of c:\...etc etc. totally disregarding the file path change I inputted. I tried restarting this a couple of times and it does the same thing.

 

It would be cool if I could save to my secondary drive of D as my main drive C is getting filed up.

Any updates on this bug?